OAuth: "Invalid access token, does not contain scopes: [user:read, user:write]"


#1

I’m working with the OAuth flow. I have an access token that works for 

https://zoom.us/api/profile

but when I use it to call https://api.zoom.us/v2/users/me I get the error “Invalid access token, does not contain scopes: [user:read, user:write].” The documentation says https://api.zoom.us/v2/users/me supports the OAuth access token. I can’t find anything about how to specify or use scopes.


#2

Hi Philip,

   You don’t have to specify the scopes but the default scope on /users/me is read only. Are you trying to modify the user profile or you are just doing a GET on /users/me ? 

 

Wei @ Zoom.  


#3

Just doing a vanilla GET. No headers except Authorization. I’m getting that same error on all the /v2/users/me/ APIs.


#4

Philip, please delete the app in our developer site and create it again. If you still see the same issue, can you please send your postman scripts to “developersupport@zoom.us” - our engineering wants to take a look. 

Thanks

Wei


#5

That solved the problem. Thanks.