OAuth with multiple environments not working

OAuth2.0 Authorization

We have a Software As A Service product and, when a customer comes on board, they have their own “instance” of the product with its own URL. In the vast majority of cases the URL is a subdomain of our .com domain, i.e. theircompanyname.ourproduct.com. A few like to have it more bespoke to them e.g. ourproduct.theircompanyname.com which then redirects to theircompanyname.ourproduct.com. My development URL is ourproduct.local.

I’ve been really struggling with the Redirect URL for OAuth and OAuth Allow List. I’ve tried to follow the documentation in https://marketplace.zoom.us/docs/guides/auth/oauth/#using-multiple-environments.

The actual redirect URL is /Integration/ZoomAuth, so for theircompanyname.ourproduct.com this would be https://theircompanyname.ourproduct.com/Integration/ZoomAuth

I have set the Development Redirect URL to https://ourproduct.local and added this to the OAuth Allow List. This is working fine.

I have set the Production Redirect URL to https://any.ourproduct.com as per the documentation and also added this to the OAuth Allow List. I have also added to the OAuth Allow List the bespoke URLs e.g. https://ourproduct.theirdomain.com.

For the bespoke URLs, when I navigate to:
I get directed to the Zoom login page which is what I would expect.

However, for the domains that should be covered by “any”, when I navigate to

I get {"status":false,"errorCode":4700,"errorMessage":"Invalid redirect url","result":null}

I can’t see what I’m doing wrong. Any help would be much appreciated.

I’ve now tried changing the app credentials again but to no avail, still getting the same invalid redirect url message:

{"status":false,"errorCode":4700,"errorMessage":"Invalid redirect url","result":null}

What I’ve tried now is I’ve changed my local development URL to https://local.sfgmentornet.com. As I mentioned in my original post, all but a couple of customers have URLs ending in sfgmentornet.com e.g. staging.sfgmentornet.com, demo.sfgmentornet.com, {companyname}.sfgmentornet.com etc.
I now have the following in my app credentials:
Redirect URL for OAuth (development): https://any.sfgmentornet.com
Redirect URL for OAuth (production): https://any.sfgmentornet.com
OAuth allow list:

As far as I can see I have followed the instructions in https://marketplace.zoom.us/docs/guides/auth/oauth/#using-multiple-environments to the letter.

Is anyone able to provide me with some assistance with this issue? I’m at the end of my tether!

Disappointed that I’ve had no responses… :frowning_face:

Hi @software2
Thanks for reaching out to us and I apologize for the lack of responses here!
I am happy to take a closer look into this issue.
I have sent you a Private Message so you can share with me more details about your app.