Password not being required when scheduling a meeting via API despite user setting

Description
When scheduling meetings via the API for users that have “Require a password when scheduling new meetings” enabled does not result in a password being required. We do not specify the password parameter when scheduling the meeting, but we’d expect a password to be auto generated due to the “Require a password…” user setting. Is this expected? An example meeting is 82529829258