Creating a scheduling meeting via the API does not automatically generate a password

The password described in the above document meets the conditions for automatic generation , but the password is not automatically generated.
("Require a password when scheduling new meetings"is enable and locked and “Require a passcode for meetings which have already been scheduled” is not checked)
The account license is at least professional.

Which setting should I enable for this?

Hi @nao.zima.apple,

Can you share the request body you’re using to create the meeting? This will help us to take a closer look. (Please leave out any personal info such as email, etc.)

Thanks!
Will

Dear @will.zoom

The request body is as follows

{
  "start_time": "yyyy-mm-ddT12:00:00Z",
  "duration": 60,
  "type": 2,
  "topic": "xxx",
  "timezone": "Asia/Tokyo"
}

Thanks!

Hi @nao.zima.apple,

Thank you for sharing this. Can I kindly ask that you check to see if your account settings have the waiting room turned on by default?

If the waiting room is turned on, a password is not required, which could be why you’re not seeing one automatically generated via API.

Let me know—thanks!
Will