Prepopulate meeting number and passcode in web sdk 1.8.6 not working

I am using the zoom web sdk/CDN/index.html code, and prepopulate the meeting number and passcode by converting the numbers into javascript variables using jquery, then inserting them into the input field by id. This worked well in version 1.7.10, but not in version 1.8.6. The input fields do not automatically insert the values of meeting number and passcode.
When testing, I can output the values as a

, so the jquery is triggering correctly. When I comment out the index.js file reference in index.html , the prepopulation also works, so there seems to be some code preventing this in your index.js code.
Note that I have limited knowledge with your API.
Tried on Chrome browser.

CODE (simplified):
this is embedded in index.html form. I have emitted the standard code of index.html

	$(document).ready(function() {	
	js_mtngid = '1234567';
	js_mtngpw = 'XXXXXXXXX';

});//close ready
				<div id=meeting_numberdisp></div>
				<input type="text"  name="display_name" id="display_name" value="1.8.6#CDN">
                <input type="text"  name="meeting_number" id="meeting_number">
                <input type="text"  name="meeting_pwd" id="meeting_pwd">
                <input type="text"  name="meeting_email" id="meeting_email">
				<input type="hidden"  name="meeting_role" id="meeting_role" value="0"> <!--- Attendee  = 0 Host = 1 Assistant = 5--->
				<input type="hidden"  name="meeting_china" id="meeting_china" value="0"> <!--- global = 0 china = 1 --->
				<input type="hidden"  name="meeting_lang" id="meeting_lang">

When loading page, the input fields are not populated. Upon submitting the form, the ?CND/js/index.js file (in zoom sdk) shows user message triggered by line 96: ‘Meeting number or username is empty’
Relevant zoom code snippet of this file:
// click join meeting button
.addEventListener(“click”, function (e) {
var meetingConfig = testTool.getMeetingConfig();
if (! || ! {
alert(“Meeting number or username is empty”);
return false;

Which version?
Web SDK 1.8.6

Hey @michael1234,

Thank you for reaching out to the Zoom Developer Forum. Just to clarify, are you importing jQuery into your application? In the newer versions of the Web SDK, jQuery is no longer a dependency so if you want to use it in your application, it will need to be imported manually.

I hope that helps! Let me know if you have any questions.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.