Prevent system to open screen saver when video call is ongoing

Is there a way to prevent system to open screen saver when video call is ongoing?

okay Thanks @j.schoenemeyer!

hey @vic.yang , Is there any better way to handle this?
as far as I know some other video call providers have this functionality inbuilt only.

in a browser the trick with the html5 video is - as far as i know - the only way to block the screensaver

in an app of course it looks completely different, e.g. Windows C++:

1 Like

Hey @shoaib

We do have an option named stayAwake in the init method, but it’s only available in Chrome or Chromium-like browser.

Thanks
Vic

1 Like

Hi Vic,

     I tried this code to prevent the screen saver to kick in when the video call is going on. I couldn't see any error in the console. But, the screen saver kicks in.

client.init(‘en-US’, ‘Global’,{stayAwake: true})

Zoom video SDK version: 1.5.1
Browser: Google Chrome
Version 107.0.5304.107 (Official Build) (64-bit)
OS: Windows 10 Pro
System Type x64-based PC

Please help me to resolve this issue.

Thanks
Krishnan

Hey @kvr

We found an issue with stayAwake in Video SDK Web and it will be fixed in the next release. For now, WakeLock is still a good solution. Here is the official guide about it.

Thanks
Vic