Production Error Version Needs to be 2.5.0 or Higher with Meeting Web SDK

I have Meeting Web SDK version 2.3.0 installed in a production environment, and when users are trying to join meetings they are getting an error

“Required. Your app version needs to be 2.5.0 or higher to join this meeting. Please update to continue”

Since the minimum version is 2.1.0, why would this error start happening now?

This is a production error. Can someone help please?