QOS data is missing from API calls

Hi there, I am currently working with the Zoom API’s /metrics/meetings/{meetingId}/participants/qos endpoint to obtain QOS data from specific users (specifically looking to gather video bitrate kbps), but I am getting some missing data when it’s their first time in the meeting room.

  • I admit the user from the waiting room a minute or less after they join it. When I let them in to the meeting for the first time and call the API, the qos data is empty. I’ve tried keeping them in the meeting for a while (over 5 minutes) before calling the API but still nothing gets returned.

  • I then put the user in the waiting room and shortly after bring them back to the meeting, this time, I successfully get data returned when I call the API with their new User ID.

  • The returned qos data also comes from their previous time in the meeting room (which is confusing as I am calling a different User ID).

I would like to resolve the above so I am able to fetch the data when the user is in the meeting room for the first time. I am not fully understanding how the QOS API is dealing with User ID’s - I’m confused that I see data from an old User ID coming in after I re-enter them to the meeting.

Extra details:
I am fetching the data from a live meeting.

The API can successfully return other user metrics such as name, datacenter etc.

The user I am testing with is currently using Zoom for iOS and the Dashboard data is coming through fine when I check the panel.

It happens both when they are admitted to the meeting with camera + mic off then turn them on, and also when they join the meeting with camera+mic on already.

Any help much appreciated!


Edit: I just worked out what was happening!

I was using the meeting.participant_admitted webhook to gather the user ID, but turns out that this is a different ID to meeting.participant_joined. Now I am using meeting.participant_joined and the user ID is returning qos every time.

Leaving this here in case anyone runs into similar trouble but feel free to close it :slight_smile:

Hey @AliceS,

Ah, I see! Glad you were able to figure it out. :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.