Rate Limit Issues

Continuing the discussion from here:

As discussed I am hitting a rate limit on my account that the developer of the discourse plugin is not.

I am also getting the same error in Zapier:

[{"code":"429","message":"You have reached the maximum per-second rate limit for this API. Try again later.","description":"Refer to URL: https://zoomappdocs.docs.stoplight.io/zapier"}]

So it is clearly something wrong with my account that is causing the errors. I’m not doing anything special with the discourse plugin or zapier that would cause multiple calls, so I’m not sure where to go from here.

Hi @davidkingham,

Just to clarify, are you using the API within Zoom or using it outside of Zoom as a plugin/Zap?If it’s the latter then which discourse plugin and Zapier Zap are you using?
For the rate limit error that you see, this usually means that the account has reached 10 or more API request.


For the Discourse plugin I created a JWT app to integrate with the plugin, which is working besides one step when I create the topic in Discourse I get the rate limit error.

In Zapier I connected to the Zoom api as described here https://support.zoom.us/hc/en-us/articles/205260649-How-To-Use-Zapier although the Zoom documentation looks a bit out of date since you do not have to enter the api keys anymore, you just sign in https://zapier.com/apps/zoom/help

I am on a Pro level plan with Zoom.

@davidkingham Can you post the full request payload?

As I said in the last thread, I’m not a developer so this is going to be a challenge. I really don’t think the issue lies in the plugin, but something on my account that is causing the error since it happens with the discourse plugin and zapier.

But, I believe this is the code in the plugin where the error is occurring, maybe @penar.musaraj would be willing to verify. I understand if you don’t want a part of this Penar since your plugin doesn’t seem to be the problem.

Hey @davidkingham,

Can you share your Zoom email or account ID so I can check your rate limits?


My account id is 112772095, I tried both the plugin and zapier today and both are working as expected. So I don’t if something changed on the backend or if it was a temporary glitch…?

1 Like

Hey @davidkingham,

May have been a glitch. Please let us know if you see this issue again.


Hi there,
I am getting the same error message on a zap between Agile CRM and Zoom. I have a free account and when I play the zap again manually it goes through fine. At this point I have no idea where to look to remedy the original error.
Any help would be appreciated.

Hey @gareth,

How are you connecting to the Zap? Via the Zoom Zap App?


Hi Tommy,
Yes it was using the Zoom Zap app. I have attached a screen shot.

That said, I have gone with another scheduling app that connects more seamlessly with Zoom.
Thanks for your time.

1 Like

You are welcome! :slight_smile: