RawAudioAPI seems to only return silence (data is only 0s)

Hi there,

I was instructed in Zoom Support to open a topic here to get assistance with regard to my issue. Previous discussion has taken place both here Setting up the AudioRawdataHelper - #2 by jon.zoom (through my colleague @tim.vandeurzen) and also in ticket 14606822 in Zoom Support

Tim has been trying to set-up the RawAudio API from the meetingsdk to record audio from a session. However, when he gives permission to the application to record, all he receives is buffers with only zeroes. Tim asked on the forums and it was suggested that he share his logs for analysis (which you can access and download through this Dropbox link Dropbox - ZoomMeetingAPI.exe_Video_4.log - Simplify your life)

He may well be doing something entirely wrong, but the forums, documentation and demo application have not helped clarify what that might be. Therefore we are reaching out to hopefully get more information this way.

Please let me know if the log that’s provided is helpful in understanding what the issue is.

Thanks,

Jonathan

Hi there,

I’m still looking for a response on this post. Can someone please get back to us as soon as possible so that we can sort this issue out?

Thanks,

Jonathan

Could someone get back to us to let us know that this problem is being investigated?

Please let me know if this issue is being investigated

Following up on this again

@digital-medium are you trying to use the RawAudioAPI to build a Zoom bot?

Hi Amanda

Are you trying to use the RawAudioAPI to build a Zoom bot?

Essentially. What we are trying to do is have our bot join a Zoom meeting and receive and record the raw audio data. So far we have managed to get the bot to join the meeting and then start a raw recording via StartRawRecording but all we receive is buffers with only zeroes.

I hope that answers your question. If not, then my original post has more information including a link to a previous developer forum post from my colleague @tim.vandeurzen which explains more about where we have got to so far.

@digital-medium that makes sense. We’ve solved a lot of these problems at Recall.ai (the universal API for meeting data).

Even if you’re not looking to use something like Recall, happy to hop on a call to help you debug this. :slight_smile:

I ran into possibly the same issue.
The callback was being called, but the data was just 0s

It’s not documented, but in addition to registering the delegate you also need the bot to join the audio.
…yeah

https://marketplacefront.zoom.us/sdk/meeting/windows/class_i_meeting_audio_controller.html#a3609743fac400f5e3dce236d4702ef87

On v5.11.4.7235 this can be done if you have the meetingService by

IMeetingAudioController *audioController = meetingService->GetMeetingAudioController();
audioController->JoinVoip();

Hopefully this helps!

Thanks for your suggestion @juan.ramon but unfortunately we checked and we confirmed that the bot was joining the audio in the same way as you described.

Can anyone from Zoom please assist with this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.