Zoom Not Allowing Recording of Raw Audio on AWS Cloud Instance EC2

We’re creating a Zoom meeting bot that joins meetings and pipes raw audio data to a web service. The code works correctly on local machines, but when deployed to AWS, we don’t see audio data. This seems to be happening because the AWS instance doesn’t have an audio output device (because it is virtual).

There is a prompt to join anyways, but obviously, this isn’t ideal for a Zoom Bot. Is there a way to disable this check?

Which Windows Meeting SDK version?

Device (please complete the following information):

  • Windows Server 2022

@tyler , this might be slightly beyond the scope of the SDK.

Nonetheless, here are some ideas which I have. Did you try enabling audio service on Windows Server and install a virtual audio device on Server 2022?

@chunsiong.zoom We gave that a try and Zoom doesn’t seem to be accepting them. We can see the audio devices in the Windows devices, but it doesn’t show up on Zoom’s list of audio drivers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.