Raw audio / onMixedAudioRawDataReceived

Hi again,

Wondering how to use the raw audio feature and exactly what we can do with it.

I’ve implemented the onMixedAudioRawDataReceived callback, which works fine, but I assumed that in this case I could disable the zoom audio playback and do the playback myself (or even modify the incoming buffer). But it seems zoom is still playing back the incoming audio as always.

I tried setting the audioOption.connect = false, but that disables the mic as well.

Basically, it would be great if the mic still worked to send audio, but we take care of audio playback via the callback (similar to how raw video works).

Thanks!

Brian

Hey @brians,

Thanks for using the dev forum! It is good to see you again :slight_smile:

Currently, the raw audio is indeed connected to the muting functionality. As in Zoom will play the playback while raw audio data is accessible and vice versa. Would you like me to submit a feature request to change this?

Thanks!
Michael

Sure – I think there are possibly two feature requests here:

  1. Ability to mute the output audio only. Right now “mute” means just the input mic, but possibly have a “muteMic” and “muteOutput” option. From what I see, the only way to mute the output is to stopAudio, which also mutes the mic.
  2. Ability to completely override the audio output playback. In effect, the zoom audio playback would be disabled and the client would be responsible for playing the audio (via onMixedAudioRawDataReceived or another method).

For us, #1 would probably take care of our use case. Thanks!

Thanks @brians for sharing your feature request. We will evaluate this.

-Tommy