React version of Web UI issue

Description
Attempting to upgrade a web ui for the Video SDK, trying to get it up to 1.9.5. On JOIN if throws some uncaught exceptions:

Browser Console Error

index.umd.js:1 Uncaught TypeError: e.util.isSupportShareMultiStream is not a function
    at oa.isSupportShareMultiStream (index.umd.js:1:1)
    at w_ (index.umd.js:1:1)
    at E_ (index.umd.js:1:1)
    at index.umd.js:1:1
    at t.project (index.umd.js:1:1)
    at t._next (index.umd.js:1:1)
    at t.next (index.umd.js:1:1)
    at e._subscribe (index.umd.js:1:1)
    at e._trySubscribe (index.umd.js:1:1)
    at e.subscribe (index.umd.js:1:1)

Which Web Video SDK version?
Trying to upgrade from 1.6.0 to 1.9.5

Video SDK Code Snippets
fails here and the exception never makes it to the console.log in the catch (yes the arguments are valid):

        await zmClient.join(meetingArgs.session, meetingArgs.token, meetingArgs.user, meetingArgs.password).catch((e) => {
          console.log(e);
        });

To Reproduce(If applicable)
Steps to reproduce the behavior:
Try to join a session from the web. I’ve tried using node versions from 14-20 with no luck

I’ve downgraded it a bit, so Video SDK version 1.8.5, I get an audio issue and still can’t join:

index.umd.js:1 Uncaught TypeError: JsMediaSDK_Instance.util.getAudioFeatureFlags is not a function
    at Ws.getAudioFeatureFlag (index.umd.js:1:1)
    at eS (index.umd.js:1:1)
    at index.umd.js:1:1
    at t.project (index.umd.js:1:1)
    at t._next (index.umd.js:1:1)
    at t.next (index.umd.js:1:1)
    at t._next (index.umd.js:1:1)
    at t.next (index.umd.js:1:1)
    at t._next (index.umd.js:1:1)
    at t.next (index.umd.js:1:1)

If I downgrade again as far as Video SDK 1.8.0, I can join a session and start the video, but my audio fails like so:

index.umd.js:1 Uncaught (in promise) TypeError: JsMediaSDK_Instance.util.isSupportAudioDenoise is not a function
    at Qs.isSupportAudioDenoise (index.umd.js:1:1)
    at wE (index.umd.js:1:1)
    at index.umd.js:1:1
    at zO.startAudio (index.umd.js:1:1)
    at n.value (index.umd.js:1:1)
    at o.value (index.umd.js:1:1)
    at r.value (index.umd.js:1:1)
    at e.value (index.umd.js:1:1)
    at video-footer.tsx:109:1
    at handleClick (button.js:177:1)

Troubleshooting Routes
I can’t get the video or audio working on the sample app either.
I’ve tried using Node vers 14 up to 20. I’ve tried downgrading the SDK down to as far a 1.8.0

Device (please complete the following information):

  • 16GB RAM Intel® Core™ i7-4790 CPU @ 3.60GHz × 8
  • Ubuntu 20.04
  • Chrome
  • Version 121.0.6167.160 (Official Build) (64-bit)

Hey @DanPiccolo

Thanks for your feedback.

Have you specified the dependentAssets in the client.init method(the second parameter)?

If so, can you check if these resources have been updated with the latest Video SDK Web package?

Thanks
Vic

Yes, I specified to a local folder on my machine, and hadn’t updated those files locally to the new SDK version