[Regression] LTI Pro - When scheduling a meeting the tracking_fields are not set

Description

When scheduling a meeting via the LTI Pro plugin in a learning management system, the tracking_fields are not populated. As we rely on the information within the tracking_fields this is a really big bug. This was working before!

Error

The tracking_fields are not set.

Which App?

How To Reproduce

  1. Setup tracking_fields in Zoom.
  2. Configure the tracking_fields in LTI Pro (see documentation).
  3. Open the LTI Pro Plugin in your Learning Management System.
  4. Schedule a new meeting and note the meetingId.
  5. Use the Zoom API to request the meeting details from the previously noted meetingId . Use a simple GET request to https://api.zoom.us/v2/meetings/: meetingId

Expected results:

The following JSON data should be returned (shortened):

{
  "uuid": "0JJXE59xxxxxxFlWA==",
  "id": 979300000893,
  "host_id": "o7GqrVmASDFM_VZ916qlw",
  "host_email": "name@domain.at",
  "assistant_id": "",
  "topic": "test",
  ...

  "settings": {
    "host_video": false,
    "participant_video": false,
    "cn_meeting": false,
    ...

  },
  "tracking_fields": [
    {
      "field": "moodle_course_id",
      "value": "21262",
      "visible": false
    },
    {
      "field": "moodle_guid",
      "value": "tuwel.tuwien.ac.at",
      "visible": false
    }
  ],
  "pre_schedule": false
}

The actual result:

The following JSON data is returned (shortened). Note the missing tracking_fields :

{
  "uuid": "0JJXE59xxxxxxFlWA==",
  "id": 979300000893,
  "host_id": "o7GqrVmASDFM_VZ916qlw",
  "host_email": "name@domain.at",
  "assistant_id": "",
  "topic": "test",
  ...

  "settings": {
    "host_video": false,
    "participant_video": false,
    "cn_meeting": false,
    ...
  
  },

  "pre_schedule": false
}

Screenshots
None.

Additional context
None.