Tracking Fields Not Showing in "Get Meeting" Request From Zoom API

Description
We are trying to see the tracking fields associated with scheduled zoom meetings:
https://api.zoom.us/v2/meetings/{meeting id}

Error
Tracking_Fields array is missing from JSON response from rest call.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meeting

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Create a meeting (with the zoom api) with a tracking field array
    example:
    ,“tracking_fields”: [
    {
    “field”: “lmsSubjectPath”,
    “value”: “31”
    }
    ]
  2. Get the ID from the resulting response
  3. Make a get meeting call with the created meeting ID
  4. Review response JSON body and look for tracking_fields
  5. Unable to see the tracking fields in the response

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Please let us know if we are structuring our call incorrectly here is the current pattern we are following:
“tracking_fields”: [
{
“field”: “string field name”,
“value”: “string field value”
}
]

We are trying to figure out how to schedule meetings that will show in the Canvas LTI for zoom.
We are hoping that the LTI is linking the Zoom meeting with the Canvas course site using the tracking_field.

Please let us know if you can offer any assistance or if we should go else where for advice.

Hey @jroorda,

Can you share your full request body so I can try to reproduce the issue?

Thanks,
Tommy

sure!
Please see below:

    {
    "topic": "15.000 Test Course CREATED BY API",
    "type": 8,
    "start_time": "2020-04-23T21:00:00Z",
    "duration": "90",
    "timezone": "America/New_York",
    "password": "15000",
    "agenda": "Test Course CREATED BY API",
    "settings": {
        "host_video": true,
        "participant_video": true,
        "cn_meeting": false,
        "in_meeting": false,
        "join_before_host": false,
        "mute_upon_entry": false,
        "watermark": false,
        "use_pmi": false,
        "approval_type": 2,
        "audio": "voip",
        "auto_recording": "none",
        "enforce_login": false,
        "enforce_login_domains": "",
        "alternative_hosts": "jeffd@mit.edu",
        "close_registration": false,
        "registrants_confirmation_email": true,
        "waiting_room": false,
        "registrants_email_notification": true,
        "meeting_authentication": false
    },    
    "recurrence": {
        "type": 2,
        "repeat_interval": 1,
        "weekly_days": "3,5",
        "end_date_time": "2020-05-09T15:00:00Z"
    },
    "tracking_fields": [
    	{
    		"field": "lmsSubjectPath",
    		"value": "31"
    	}
    ]
}

Hey @jroorda,

Did you add the respective tracking field first:

Once I added a tracking field, and then set it in the Create Meeting API request I was able to get the tracking_fields in the response.

{
    "uuid": "rfB6f6nrQI+01hFcfx7zBQ==",
    "id":,
    "host_id": "",
    "topic": "15.000 Test Course CREATED BY API",
    "type": 8,
    "status": "waiting",
    "timezone": "America/New_York",
    "agenda": "Test Course CREATED BY API",
    "created_at": "2020-04-28T19:55:57Z",
    "start_url": "",
    "join_url": "",
    "password": "",
    "h323_password": "",
    "pstn_password": "",
    "encrypted_password": "",
    "occurrences": [
        {
            "occurrence_id": "1588107600000",
            "start_time": "2020-04-28T21:00:00Z",
            "duration": 90,
            "status": "available"
        },
        {
            "occurrence_id": "1588280400000",
            "start_time": "2020-04-30T21:00:00Z",
            "duration": 90,
            "status": "available"
        },
        {
            "occurrence_id": "1588712400000",
            "start_time": "2020-05-05T21:00:00Z",
            "duration": 90,
            "status": "available"
        },
        {
            "occurrence_id": "1588885200000",
            "start_time": "2020-05-07T21:00:00Z",
            "duration": 90,
            "status": "available"
        }
    ],
    "settings": {
        "host_video": true,
        "participant_video": true,
        "cn_meeting": false,
        "in_meeting": false,
        "join_before_host": false,
        "mute_upon_entry": false,
        "watermark": false,
        "use_pmi": false,
        "approval_type": 2,
        "audio": "voip",
        "auto_recording": "none",
        "enforce_login": false,
        "enforce_login_domains": "",
        "alternative_hosts": "",
        "close_registration": false,
        "registrants_confirmation_email": true,
        "waiting_room": false,
        "registrants_email_notification": true,
        "meeting_authentication": false
    },
    "recurrence": {
        "type": 2,
        "repeat_interval": 1,
        "weekly_days": "3,5",
        "end_date_time": "2020-05-09T15:00:00Z"
    },
    "tracking_fields": [
        {
            "field": "Test",
            "value": "TestValue2"
        }
    ]
}

Thanks,
Tommy

Hi @tommy, can you confirm that if the “Visible to Users” option has to be checked for the tracking_fields to be accessible in the get meeting API?

If so, is there a plan to develop a feature such that we can separate the options of “visible in API” vs. “visible to users”?

Hi Tommy,
Thank you for the response.
I am getting permissions from our admin to create a new tracking field to test it out.

But for this example I am trying to use a tracking field that has already been established.
The tracking field I am trying to use is supposedly populated by a 3rd party Canvas LTI.

Here is the tracking field I was trying to use:
{
“total_records”: 1,
“tracking_fields”: [
{
“id”: “NOnrs-kYQRGaFKWwV4RzZA”,
“field”: “lmsSubjectPath”,
“required”: false,
"visible": false,
“recommended_values”:
}
]
}

It is possible that there is some reason (to expanding on vhu comment) that I am unable to pull the values in this tracking field via the API because of the visibility setting?

Thanks again for all your help it is appreciated!

Justin

Hey @vhu,

Yes, visible to users has to be checked. I will bring this up to the team to see if we can provide this functionality to the API and hide on the UI.

Thanks,
Tommy

Hey @jroorda,

That is possible. Make sure the tracking field is visible and let me know if that fixes the issue.

Thanks,
Tommy

That will be fantastic! Our customers have expressed confusion from their end-users because of our use of the tracking field. It will be great if we can allow the field to be accessible through the API without confusing the end-users.

Happy to help! :slight_smile:

We are in talks with our product team to figure out how we can accomplish this. (ZOOM-168958)

Thanks,
Tommy

We would also be very happy to have this functionality. It would also be nice if the Chrome and FF scheduling extensions didn’t prompt users to fill out these fields unless they were required.

A popup box asking for panopto_folder_context is confusing and unhelpful.

Hey @cbarbour,

Thanks for your feedback! :slight_smile:

We are currently working on a solution.

-Tommy

Hey @cbarbour, @jroorda, @vhu,

The set the non-visible fields through Create/Update Meeting APIs feature will be released this month, stay updated here:

https://marketplace.zoom.us/docs/changelog

Thanks,
Tommy

1 Like

Hey @cbarbour, @jroorda, @vhu,

Just following up, we released this at the end of last month. :slight_smile:

Please let me know if you have any issues setting the non UI visible tracking fields via the API.

Thanks,
Tommy

Thank you for making this happen! We’ve confirmed that the non-visible field can now be accessed via the API.

1 Like

You are welcome @vhu! :slight_smile:

-Tommy

Can you explain where this is noted in the release notes? I’m not seeing it in listed anywhere. Perhaps I’m not sure what to look for though?

Hi @cbarbour,

We’ve updated our documentation to include these fields in the schema samples for our Create and Get a meeting endpoints.

In regards to our release notes, I will double check with our team to ensure this is included in our Changelog. Thanks for raising this! cc: @shrijana.g

Best,
Will

Hello @will.zoom,

It’s great for our institution and users of Zoom that they no longer have to see certain tracking fields that are meant to be populated via Zoom LTI Pro launches; however, we’re no longer seeing the tracking fields when trying to look up past meetings in the Admin Dashboard. Would it be possible to allow those fields which are hidden from end users to be visible in the Dashboard and reports?

Thanks,

Jaime

Hey @jaime_bermudez,

Thanks for the feedback on this—I can definitely appreciate how this would be helpful, and I’ll be happy to raise this with our team. In the meantime, if you’re so inclined, you’re welcome to post this in our #feature-requests channel as well!

Thanks,
Will