Request permission to unmute participants API

I’m trying to set the “request_permission_to_unmute_participants” setting using the Create Meeting or Update Meeting API, but it’s not storing the setting. My other settings set…just not “request_permission_to_unmute_participants”

here’s a snippit of my settings parameters…

“settings”: {
“mute_upon_entry”: true,
“alternative_hosts”: “xxx@zzz.com”,
“request_permission_to_unmute_participants”: true
}

Any ideas???

Thanks
Robert

Hi @zingersigns,

Thanks for reaching out about this.

As a first step, is it possible to confirm where in our Create Meeting documentation you’re seeing this field? In taking a quick look I’m not immediately seeing the “request_permission_to_unmute_participants” field as an API supported setting. But in case I’m missing it, please let me know!

Thanks,
Will

I was able to figure out my problem.

When I update(PATCH) a meeting with the “request_permission_to_unmute_participants” setting, using the API.

The “request_permission_to_unmute_participants” setting won’t set, unless “Request permission to unmute” is enable for the account that scheduled the meeting.

Thanks for your response.
Robert

Hi @zingersigns,

Ah, I see. Yes, that makes sense—I’m glad you figured it out.

Best,
Will