"Required param is null or missing" returned when using chat bot api to send message


#1

Followed the chat bot guide, " {“message”:“Required param is null or missing”,“code”:7001}"  returned when send message to a channel.The  request body is below:

{
    “robot_jid”:“psjmXXXXXXXiq3w@xmpp.zoom.us”,   ----   the robot id of the market app
    “to_jid”:“7f9cc71XXXXXXX267007a73@conference.xmpp.zoom.us”,  —  a group jid of [list channels] command response
    “account_jid”:“XMdUXXXXXXXXXvp2Li8Nw5yw”,    — a user id of [list users] command respose
    “content”:{
        “head”:{
            “text”:“main title”,
            “style”:{
                “color”:"#000",
                “bold”:true
             },
            “subHead”:{
                “text”:“system message”
            }
        },
        “body”:[{
            “type”:“message”,
           “text”:“Message body”
        }]
    }
}

Need help…

Further question is [Why the chat channels can be listed with api , but can’t be created] ?


#2

Hi Fei, 

Can you change account_jid to account_id?

Also, you can create chat channels via our Create an IM Group API - https://devdocs.zoom.us/v1.0/reference#imgroupspost.

Thanks


#3

Thanks Michael. Followed the api reference of “https://devdocs.zoom.us/v1.0/reference#imchatmessagespost”, the parameter is " account_jid". May be the reference should be corrected。

But after using “account_id” instead of “account_jid”,  it still not working. " The user does not have authorization, the application cannot send the message" returned when using development client id&securet ,  and " token do not match robotJid, the robotJid :XXXXXXXX" returned when using production client id&securet.

Need your help.

ps: I didn’t summited my app in the market yet, the submit proccess stopped in the last step. 

 

 

 


#4

Hi Fei, 

I’ll reach out to our Engineers to see why the error is happening and follow up with you asap. 

Thanks


#5

Thanks…If there is any progress, please contact me asap.


#6

Hi Fei, 

It appears to be an error on our end, we did not include the redirect url within the sendbotmessage.js file. We have updated it, so now after you go to the redirect url your bot message should work. 

Thanks

 


#7

I had noticed the issue of [sendbotmessage.js], and tested the api by postman with token which returned after user login.

Currently, it still doesn’t working…

I have no idea to [token do not match robotJid]. I copied the robotid from below location, and confirmed that I have used the right client id&secret.

Did I missed something?


#8

Hi Fei, 

Could you send us your API request for the chat bot to developersupport@zoom.us along with your accountID, token info etc… so that we can take a closer look?

Thanks


#9

Detail has been sended by email.Thank you.