Restarting local video takes a long time. Missing method in documentation

Hi,
i am using Fully Customizable Web Sdk for zoom integration in our website. But whenever i try stopping and restarting local video quickly it takes a long time to re-render the video. Sometimes it takes almost like a min or two to get the local video feed back again.

I tried searching for a way to clear the canvas manually. Found “clearVideoCanvas()” method in documentaion online. But the doc i got from zoom-instant-sdk-web-1.0.0.zip does not have this method.

Here are my questions:

  1. How to facilitate quick start/stop video functionality?
  2. How do i clear the canvas manually?
  3. Why is there a mismatch between online documentation and the one i got ?
  4. What is the latest version of Fully Customizable Web Sdk ? is it 1.0.0?
  5. If there is a newer version (> 1.0.0) of Fully Customizable Web Sdk how do i get it?

Steps to Reproduce:
i. Initiate a client
ii. Start video
iii. Stop video and try restarting the video quickly
iv. Do this couple of times

Result:
Re-rendering the local video takes a lot of time

Fully Customizable Web Sdk:
version: 1.0.0

Device:

  • Device: Desktop
  • OS: Linux and Windows
  • Browser: Chrome, FireFox

Any help will be greatly appreciated. Thanks in advance

Regards
Md. Mehedi Hasan
Software Engineer

Hey @hasan.md ,

Thanks for letting us know about this issue. We are investigating it and will report back soon. (CS-3067)

-Tommy

Hey @hasan.md ,

After speaking with our engineers, we want to suggest that you upgrade to the latest version, 1.0.2, which can be found in your marketplace app settings.

As for your additional questions, here are the answers I have for you:

How to facilitate quick start/stop video functionality?
SDK uses ImageCapture to grab the frame from the camera device, it could take some time.

How do i clear the canvas manually?
Invoke the stopRenderVideo method to stop rendering the video, if you want to set a background color for the canvas, use clearVideoCanvas method.

Please let me know if that helps! :slight_smile:

Thanks,
Tommy

Hi @tommy
Got the latest sdk in marketplace. Tried the sample app as well. Seems like some of the delay was significantly reduced in the latest sdk.
I am moving on to the v1.0.2 now. Quite a massive change in the latest websdk build.
Appreciate your reply. Will let u know if i face any new challenges.
Thanks and regards
Mehedi Hasan
Software engineer

1 Like

Glad to hear that! :slight_smile:

Please do let us know if you run into any issues, and thanks for using Zoom!

-Tommy

Hi @tommy ,

We have been trying to integrate the instantwebsdk 1.0.2 as you suggested. Previously we integrated the websdk 1.0.0 fully in our Angular application.
Quite frankly, we did not anticipate such a massive change in the latest SDK. It seems like the latest SDK is a major version instead of a minor from your side.
The previous integration is not really upgradable to the latest in this case. We now have to start from the beginning again in case of video rendering using the latest sdk, which would take a significant amount of time.

We are in a time crunch now and we are looking for a way to release our web version with the previous SDK (1.0.0). Meanwhile, we will start integrating the latest SDK paralelly and release it when it is ready.
The blocker that I already mentioned for the version 1.0.0 - “Stop/Start Video halts the video canvas and video shows after a significant time (> 20 seconds)”.
Is there any way to solve this one in the previous SDK (1.0.0)?

Thanks in advance,
Md. Mehedi Hasan

Hey @hasan.md ,

Let me see what we can do, but I cannot promise we will be able to fix the issue in time for your deadline. :slight_smile:

Thanks,
Tommy

@tommy thanks a lot.
meanwhile we investigated further and found that this issue is exclusive to google chrome. Canvas gets stuck upon restarting camera, but renders as soon as i click inspect on the canvas.
Firefox on the other hand is working fine and i can start/stop camera as many times and as fast as i want.

https://devforum.zoom.us/t/restarting-camera-causes-canvas-to-get-stuck-in-chrome-but-renders-when-element-is-inspected/45232

i created this topic yesterday. Please advice on it .
Regards
Md. Mehedi Hasan

1 Like

Thanks for reporting this! :slight_smile:

I will respond on your new thread.

-Tommy

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.