Restrict host from Login while uSi


#1

By using the “start_url” from “creating a meeting API” zoom enforces the host to log in.IIs it necessary to log in. We have a pro account and created a meeting with the following action. But all the methods enforces the host for login

  1. Create A User 
  2. Cust-Create A User

#2

Hi Ammu, 

Can you make sure to the start_url is not expired?

Thanks

 


#3

Thank you for your response.

 

Please refer to the below data and attached image.

 

JSON data   - For create a meeting 

{ “topic” :"Video telecall with Ammu ",
“type” :2,
“start_time” :“18181818-JulJul-2727T1414:0707:0000”,//Schedulded TIME
“current_time_ref” :“2018-07-27 11:23:44”, //Our cuurent TIME FOR your reference
“timezone” :“Asia/Kolkata”,
“password” :327530,
“settings” :{ “duration” :NULL,
“join_before_host” :FALSE,
“host_video” :TRUE,
“participant_video” :TRUE,
“cn_meeting” :FALSE,
“in_meeting” :FALSE,
“enforce_login” :FALSE,
“auto_recording” :“cloud” },
“data_type” :“JSON” }

 

 

Response data :

 

 

{ “uuid” :“EdHr62j1QBib96LE5mYsqA==”,
“id” :735817642,
“host_id” :“SRN57EXBQI27WoDB4TLRqA”,
“topic” :“Video telecall with Ammu “,
“type” :2,
“start_time” :“2018-07-27T05:55:22Z”,
“duration” :0,
“timezone” :“Asia/Kolkata”,
“created_at” :“2018-07-27T05:55:22Z”,
“start_url” :“https://zoom.us/s/735817642?zak=eyJhbGciOiJIUzI1NiJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJTUk41N0VYQlFJMjdXb0RCNFRMUnFBIiwiaXNzIjoid2ViIiwic3R5IjoxMDAsImNsdCI6MCwic3RrIjoiaU5jOURTakZOdmJqSjFYSVBGYTJOYm1oTDVPV3JBcEpPRG1TTTRhTWdETS5CZ1FzU2xNek1ESjZSV1ZUT1VOdmFubzNNbE5TYUN0eWNWVmlSWFJYYVROWlNGWnFabmR6TVZaUVNtVkRTVDFBTkRJMVlqWTJOV1EyWmpFeU5qYzFNV0ZoWW1GaU1tRTJaVGMxTXpBNVpEYzJZVEk0TkdFeVlXRmtPRGszWlRaaE9ERmpOMk00TldSbVpqa3dZakppTWdBTU0wTkNRWFZ2YVZsVE0zTTlBQSIsImV4cCI6MTUzMjY3ODEyMiwiaWF0IjoxNTMyNjcwOTIyLCJhaWQiOiJKdHhuWUMwWVRObWNmUFdxTm1HZDV3IiwiY2lkIjoiIn0.PI7kQ8lYMFWwXKU-4eP5qUeAsAZlnjbsCa89c8kgv8U”,
“join_url” :“https://zoom.us/j/735817642?pwd=NWpRV0xTWjdmZHpIRSt6d1ZYcDljQT09”,
“password” :“327530”,
“h323_password” :“764920”,
“pstn_password” :“764920”,
“settings” :{ “host_video” :TRUE,
“participant_video” :TRUE,
“cn_meeting” :FALSE,
“in_meeting” :FALSE,
“join_before_host” :FALSE,
“mute_upon_entry” :FALSE,
“watermark” :FALSE,
“use_pmi” :FALSE,
“approval_type” :2,
“audio” :“both”,
“auto_recording” :“none”,
“enforce_login” :FALSE,
“enforce_login_domains” :””,
“alternative_hosts” :"" }
}

Loaded Screen for zoom API

 

 


#4

I am also tried with the instant meeting. The response pop-up will be ‘This meeting has been ended by the host’

 

Input JSON

{ “topic” :"Video telecall with Ammu ",
“type” :1,
“start_time” :“18181818-JulJul-2727T1212:0707:0303”,
“current_time_ref” :“2018-07-27 12:08:03”,
“timezone” :“Asia/Kolkata”,
“password” :654183,
“settings” :{ “duration” :NULL,
“join_before_host” :FALSE,
“host_video” :TRUE,
“participant_video” :TRUE,
“cn_meeting” :FALSE,
“in_meeting” :FALSE,
“enforce_login” :FALSE,
“auto_recording” :“cloud” },
“data_type” :“JSON” }

 

 

Response:

 

{ “uuid” :“lYuzJEVVQdyAUudFs0cE8A==”,
“id” :347399399,
“host_id” :“SRN57EXBQI27WoDB4TLRqA”,
“topic” :“Video telecall with Ammu “,
“type” :1,
“duration” :0,
“timezone” :“Asia/Kolkata”,
“created_at” :“2018-07-27T06:39:43Z”,
“start_url” :“https://zoom.us/s/347399399?zak=eyJhbGciOiJIUzI1NiJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJTUk41N0VYQlFJMjdXb0RCNFRMUnFBIiwiaXNzIjoid2ViIiwic3R5IjoxMDAsImNsdCI6MCwic3RrIjoiaU5jOURTakZOdmJqSjFYSVBGYTJOYm1oTDVPV3JBcEpPRG1TTTRhTWdETS5CZ1FzU2xNek1ESjZSV1ZUT1VOdmFubzNNbE5TYUN0eWNWVmlSWFJYYVROWlNGWnFabmR6TVZaUVNtVkRTVDFBTkRJMVlqWTJOV1EyWmpFeU5qYzFNV0ZoWW1GaU1tRTJaVGMxTXpBNVpEYzJZVEk0TkdFeVlXRmtPRGszWlRaaE9ERmpOMk00TldSbVpqa3dZakppTWdBTU0wTkNRWFZ2YVZsVE0zTTlBQSIsImV4cCI6MTUzMjY4MDc4MywiaWF0IjoxNTMyNjczNTgzLCJhaWQiOiJKdHhuWUMwWVRObWNmUFdxTm1HZDV3IiwiY2lkIjoiIn0.NTr5BCSPvYrMqYvlcRRMc5gw5TvgL3Y7Gp0SP2b0eew”,
“join_url” :“https://zoom.us/j/347399399?pwd=YndOK0wvYkJCdjRkYXJtNUVXMUJVZz09”,
“password” :“654183”,
“h323_password” :“496830”,
“pstn_password” :“496830”,
“settings” :{ “host_video” :TRUE,
“participant_video” :TRUE,
“cn_meeting” :FALSE,
“in_meeting” :FALSE,
“join_before_host” :FALSE,
“mute_upon_entry” :FALSE,
“watermark” :FALSE,
“use_pmi” :FALSE,
“approval_type” :2,
“audio” :“both”,
“auto_recording” :“none”,
“enforce_login” :FALSE,
“enforce_login_domains” :””,
“alternative_hosts” :"" }

}

 

The Pop-up

 


#5

Hi,

I am also checked with expired URL. For that, it shows the exact output. Please find the attached image.


#6

Hi Ammulekshmi, 

For your initial request please change “join_before_host” : FALSE , to “join_before_host” : TRUE.  This would remove the “Please wait for host to join meeting” dialog.