Running iPad app on Mac M1 does not render remote participants video

I have an iPad application that integrates Zoom SDK for video conferencing.

When I tried to run the same iPad application on Mac M1 machine it does not render the remote video

I experienced the same behaviour in the MobileRTC sample app using the latest Zoom iOS SDK.

Which iOS Client SDK version?

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Launch the MobileRTC sample app on Mac Mini M1 (by selecting the target My Mac (designed for iPad)
  2. Launch the MobileRTC Sample app on an iPhone device
  3. Share the local video from the iPhone device.

Actual Result:
Remote video of the iPhone device should be displayed on the Mac M1 machine instead of it shows a black screen. There were a few instances that remote video was displayed but then it got stuck.


Mac Machine

  • Device: [Mac Mini M1 2020]
  • OS: [macOS Big Sur 11.1]


  • Device: [iPhone 8]
  • OS: [iOS 14.4.2]

Additional context
In the console logs, this error was getting logged while remote video is shared:
**2021-05-04 17:10:48.644661+0500 MobileRTCSample[8686:230422] [aqme] AQME.h:258:IOProcFailure: AQDefaultDevice (188): skipping output stream 0 0 0x0**

I have noticed that it is hit or miss. Sometimes it does show for me, but I have seen it fail more times than work.

Hey @usman.awan,

Thanks for using the dev forum!

I will inform the engineers of this. To confirm you also tried the latest version in addition to v5.2.42037.1112 correct? That version is not the latest version.


Hi @Michael_Condon,

I haven’t check in the latest Zoom SDK since I was not aware that Zoom now have the latest SDKs available from the app marketplace instead of Github.

I will update the ticket after checking in the latest SDK.


Hey @usman.awan,

Sounds good!


@Michael_Condon I have checked with latest Zoom SDK v5.5.12511.0421 and I am experiencing the same issue.

Hey @usman.awan,

I see, that is disappointing. Can you reproduce the issue one more time and then send your SDK logs over to me at so that I can file a bug report? Provide as much code, reproduction steps, and info as you can. Please omit any personal information about your application or code.


@Michael_Condon I have send the debug SDK logs along with video recording. The support ticket# 11060469.

I will be looking forward for a prompt response because as of now we have a blocker in providing the iPad App compatibility for Mac M1.

Hey @usman.awan,

Thank you, will follow up there.


Hey @usman.awan,

To confirm, you are only seeing this on the iPad simulator correct?


Hello @Michael_Condon,

No, I don’t have any issues with running iPad Simulator. I am running the iOS application directly on Mac M1 that’s where is the issue occurs.

With the release of Mac M1 machines. Apple now allows users to directly download the iPhone & iPad applications from Appstore. We are getting complaints from a client that our iPad Apps do not render videos while running the app on Mac M1.

This issue is reproducible latest MobileRTCSample project running on Mac M1 as the target.

Can you please ask the developers to at least run the project on Mac M1 with the latest Xcode 12.4 or 12.5 and I am sure that will get more information about the issue?

Hey @usman.awan,

The latest version of the SDK does not yet fully support running iOS applications on M1 Mac’s. For the time being, I would suggest using a physical iOS device. We will let you know when this is supported.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.