Sample Node App using JWT issue

Description
I have run into an issue while making a sample Zoom API call using JWT as directed on https://github.com/zoom/zoom-api-jwt. I have successfully cloned that repository, installed the dependencies, installed the updated versions of Git and node in the process, input my API Key & Secret credentials and set the environment variable (NODE_NEV=production). However, I have now hit a blockade and I cannot figure out why.

Error
The issue I have run into is that when I start the node app (by type node index.js in the terminal), I get a message saying “Example app listening on port 3000!” but I am unable to type anything when I should be able to enter my email address and view the APIs response. When I exit the program by typing Ctrl+C, I get a message saying that " ‘whatever you typed after starting the node app’ is not recognized as an internal or external command,
operable program or batch file."

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
Not sure. I am still a beginner at this. Please refer to the GitHub repository linked above.

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Follow the steps on the GitHub repository
  2. I had to install Git and node from scratch so doing so might help too.

Screenshots (If applicable)

Additional context
This is my first time working with APIs which is why I begun with the tutorial and had to install a bunch of things to only even get started. Please let me know if I need the newly installed apps (Git, node, etc.) to work on a particular setting for this to work.

Hey @njp-xyz,

It seems like this could be an issue specific to your environment or commands—have you had a chance to try testing out our API endpoints from within the documentation or using a tool like Postman? You may find this a bit simpler as you’re getting started.

From within our documentation, you can simply add your JWToken to the auth section:

Let me know if you have better luck with this!

Best,
Will

Hi Will,
Thanks for the response but I figured out what my issue was. It was something on my end due to my lack of knowledge of working with APIs.

@njp-xyz No worries! I’m glad you figured it out.

Best,
Will