Schedule_for makes meeting visible for every user with "schedule for"-privileges

Updating a meeting with “schedule_for” parameter makes the meeting visible to every user with “Schedule Privilege”

I want to transfer an existing meeting to another host. The old host has “schedule privilege”. API call is successful (response 204). Meeting is successfully transferred to new host.
BUT the meeting also appears in the meetinglist of every user that has “schedule privilege”.

The meeting should only be visible (after the successful transfer) to the new host

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?{meetingId}
body: {
    schedule_for: {username@mydomain}

How To Reproduce (If applicable)

  1. schedule a meeting for user1 → meeting_id = my_meeting_id
  2. add user1 to “schedule privilege” of user2
  3. add user3 to “schedule privilege” of user2
  4. make API call to{my_meeting_id} with body { schedule_for: email_address_of_user2 }
  5. take note of the success response code 204
  6. take note that meeting is scheduled for user2, and visible in meeting list of user2 (THIS IS WANTED RESULT)
  7. note that meeting is also visible in the meeting list of user3 (THIS IS UNWANTED SIDE EFFECT)

This is my first post on the forum. Is it possible to ask a staff-member for input?

cc @MaxM

Hi @thomas.villa

Thank for reaching out to the Zoom Developer Forum! I am happy to help here.
I will go ahead and try to replicate this behavior on my end and will come back to you shortly with some updates.

1 Like

Thank you very much!

Could you please also take a look at my second issue “Dutch not supported for language interpretation via API call to create meeting”? For some reason it was automatically flagged as spam, but I can assure you it was not meant as spam.

I appreciate any input you can provide, thank you in advance.

Kind regards

Hi @thomas.villa

Thanks for your patience while I investigate this issue further.
When you refer to your second issue, you are saying that you would like to have Dutch supported?

Here is a helpful link on how to use Language Interpretation

Hope this helps!

Dear @elisa.zoom

thank you for the response. I will exercise some patience :wink:

Regarding the second issue, I’m sorry to say your link is not helpful at all. I explained in great detail what my issue is. I did it in a kind and respectful manner. Unfortunately my post was automatically flagged as spam. I do not understand why. If you could help me understand, I am of course very much willing to adjust style or wording if necessary.

We are able to use Language Interpretation. We use it for French → Dutch, and Dutch → French. Scheduling a meeting with this enabled via the Client (GUI) works as expected.

The issue is that the API-call fails with NL as language, where the same body succeeds with for example US as language.

Succeeds: POST a request to with body

{... "settings": {
        "language_interpretation": {
            "enable": "true",
            "interpreters": [{
                    "email": "",
                    "languages": "FR,US"

Does not succeed: POST request to with body except for different countrycode

{... "settings": {
        "language_interpretation": {
            "enable": "true",
            "interpreters": [{
                    "email": "",
                    "languages": "FR,NL"

I also refer to this issue: Set italian as one of the interpreter language - #4 by MaxM
Setting Italian as language apparently also needs to be added. Is this also the case for Dutch? Can this be considered?

I hope I have clarified my issue. And i hope this reply does not get flagged as spam or inappropriate :slight_smile:

I hope to hear from you soon.

Kind regards,


Hi @thomas.villa

Hope you are doing great. I have been testing this second issue on my end and I had no issues when calling the API with the languages “FR,NL”. I got a 201 response and had no issues setting this up.
I used the code snippet that you shared with me.

In that case could you please share the error that you are getting or how is this failing on your end???

And by the way, sorry to hear that your first post was flagged as spam. Luckily this wont happen again


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.