Screen sharing button not working in Web SDK

Description
On Chrome 87.0.4280.141 (Official Build) (x86_64) on macOS 10.15.7, the “Share Screen” button in the Zoom Web SDK (1.8.6) does not seem to work.

Error

  • When clicking on the button, nothing happens. It was expected that a dialog would appear.

Which version?
1.8.6

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Run the sample web application locally.
  2. Click on “Join Audio by Computer”
  3. Click on “Share Screen”

Device (please complete the following information):

  • Device: MacBook Pro
  • OS: macOS
  • Version: 10.15.7
  • Browser: Chrome 87.0.4280.141

Additional context

The SDK is embedded within an IFRAME in a React application, it is hosted via a HTTPS connection.
In theory, the Content Security Policy on the CDN or the IFRAME might limit the access to certain browser APIs, but the issue can be reproduced locally - independently whether the SDK is displayed standalone or within an IFRAME.

If there is a possibility to hide the screen sharing functionality, this would resolve this issue as well (for my use case).

Hey @matti ,

We are aware of this, and have seen this happen also when the Web SDK is embedded in a web view:

Since the Web SDK is not designed to work within an iFrame, my best suggestion for you is to use it outside of the iFrame and screen sharing should work. :slight_smile:

Thanks,
Tommy

Hello @tommy , thank you for the message.

I can reproduce the issue also when the SDK is running outside an IFRAME. The button does not do anything.

In order to get more information, I would need additional information on the root cause as no errors are logged. Is it due to a lack of permissions inside an IFRAME? Are you aware of a Content Security Policy preventing access to screen sharing?

Hey @matti ,

During the initial screen share, have you provided access for your browser? Perhaps you can check your computer and browser permissions.

Thanks,
Tommy

Hello @tommy, thank you for the message. All browsers tested have access to screen sharing.

Hey @matti,

I wasn’t able to reproduce this issue with our Sample Web App when serving over HTTPS. Do you see the same issue when using the sample app? If not, are you able to share a public git repo or a snippet of the code that you’re using to test this?

Thanks,
Max

@MaxM @matti 'm seeing this same issue on my side as well.

It’s working perfectly in a React application, but not inside an Electron application.

Zoom Web SDK Version: 1.8.5 and 1.8.6 (both have the issue)

Thanks

Hey @matti,

Thank you for reaching out to the Zoom Developer Forum. We have a separate SDK when working with Electron. Have you followed our steps to set up and install the electron SDK? You may also be interested in the Electron Sample App that we have.

If you continue to have issues, I recommend posting in the #client-desktop-sdk:electron category so that a subject matter expert can assist you.

I hope that helps!

Thanks,
Max

Hello!

Thank you for the help. I have found out eventually that screen sharing in the settings of the Zoom meeting itself was disabled.

Nevertheless, @MaxM : The Zoom SDK behaves in this case differently than the native client, it ALWAYS shows the “Share Screen” button independently of the meeting settings.

I would regard this as a bug.

Regards

Hey @matti,

Thank you for the update. I’m glad to hear that you were able to resolve your issue! If you want to hide the screenshare button when the meeting starts, you can set the screenShare field on the init() function to false when initializing the meeting.

image

Due to this, I wouldn’t say this is a bug but more of a missing feature. If you would like this feature to be considered for a future release, I recommend posting in the #feature-requests category.

Thanks,
Max

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.