sdkAuth call always fails with ZoomSDKError_ServiceFailed error

We previously have had a successful integration of the MobileRTC SDK on the iOS platform. Now we are trying to do the same on Mac. Unfortunately, in the ZoomSDKSample for MacOS -[ZoomSDKAuthService sdkAuth:…] and -[ZoomSDKAuthService sdkAuth:… appSecret:…] both fail with the same valid credentials and return ZoomSDKError_ServiceFailed error.

We are using the latest at the moment SDK version 5.2.41735.0929

Steps to reproduce the behavior:

  1. Download and build the SoomSDKSample app
  2. Enter “” as the domain
  3. Enter the valid JWT generated with the valid credentials
  4. Call the -[ZoomSDKAuthService sdkAuth:… appSecret:…] with the valid credentials
  5. See error
  • Device: iMac Late 2017
  • OS: Catalina 10.15.6

I’d like to emphasize - the same credentials are successfully used on the iOS platform for the MobileRTC framework.

Thank you!

Hi @mcfly,

Thanks for using Zoom SDK. Sorry to hear that you are facing such issue. Could you enable the SDK log feature and provide the SDK log for us to further investigate?

You may enable to SDK log using:

ZoomSDK* sdk = [ZoomSDK sharedSDK];
[[ZoomSDK sharedSDK] enableDefaultLog:YES fileSize:5];
[sdk initSDK:useCustomizedUI];

And you will find the SDK log here: ~/Library/Logs/appName

Thank you.

Hello @carson.zoom,
Thank you for the reply. I have enabled the SDK log, but the folder you mentioned (in my case it is ~/Library/Logs/ZoomSDKSample) is empty.
Maybe I am doing something wrong?
Best regards

Hi @mcfly,

Thanks for the reply. I would like to confirm that if you have moved the folder “ZoomSDK” into the sample project folder “ZoomSDKSample”(in the same level as the ZoomSDKSample.xcodeproj)?

If the folder is not being moved into the sample project, then it could result in the error you are getting.

Hi @carson.zoom,
Thank you for the suggestion. I have copied the ZoomSDK folder to the sample project folder. Unfortunately, there are still no logs and I still get the ZoomSDKError_ServiceFailed error.
Do you have any other suggestions? Or maybe I can provide some additional information?
Thank you and best regards

Hi @mcfly,

Thanks for the reply and pardon the late response. Could you check the files in the following path: Target->Build Phases->Copy Files and see if it includes all the lib in the ZoomSDK folder?

Normally the error code that you are getting is caused by the libs that are not found/linked by the project.


Hi @carson.zoom,
There is no Target->Build Phases->Copy Files phases in the sample project. All the contents of the ZoomSDK is included in the “Copy Bundle Resources” phase except for .frameworks and .dylibs that are all included in the Embed Frameworks phase. If this is incorrect, can you please point out what is the correct contents of the Copy Files phase?

Thank you and best regards.

@jon.zoom it looks like we’re not the only ones that are not able to get the SDK to write logs. May I ask you to investigate the issue and provide support and guidance?

Hi @tmiskiew,

Thank you for pointing this out.

In the future, I would ask that you please link to external threads from within your own thread rather than tagging me in them unless you are continuing the discussion of the external thread. Posting here may cause additional unnecessary notifications for other users of our forum when there has not been an update on their topic. :slightly_smiling_face:

Thank you for understanding!

As you can see this person never got a reply to this issue as your colleague never explained why logs stopped being ignores. Ignoring this problem won’t solve it I’m afraid.

Hi @tmiskiew,

Please be mindful of our community guidelines when posting to this forum. We strive to keep this forum as open, friendly, and helpful as possible. Following our guidelines helps accomplish this. Repeated and/or severe offenses may result in temporary or permanent suspension of your posting privileges.


I’m very sorry @jon.zoom I didn’t mind to offend anyone. I’m very frustrated that we and other people have been keep asking this question for over a month now to no avail. I provided simplified code and settings. I offered a ready to compile code. It would take to mouse clicks to open and run the project…

With the most recent SDK version and after ensuring that all @rpath paths are loaded correctly, the error is gone. Initially the problem was that our product is built upon Project Catalyst that is iOS and SDK is Mac, so we tried to place it inside the native MacOS bundle. Everything started working when we placed all the dependencies of the SDK into the /Frameworks of the main project and marked them as “MacOS only”. The SDK itself however is still hosted within the MacOS native bundle. The question can be closed.

I’m glad to hear you were able to resolve this, and thanks for providing the context around your implementation!

Unfortunately I have the same or similar problem, I always get the ZoomSDKError_ServiceFailed error. How can I send you my log files, it doesn’t seem I can attach it here. I guess the log files are encrypted so only you guys can read them?

Hi @sdk_testing,

Sorry to hear you’re running into this issue as well. Before we look into your SDK logs, can you provide a code snippet showing how you are setting up the SDK auth? Also, if you are using a JWT, please provide the payload (with your developer credentials removed).


Thank you for the fast reply!

In the meantime I figured out that it was as you mentioned before caused by libraries not being found/linked by the project. I made sure that in Xcodes Build Phases tab “Link Binary with Libraries” and “Copy Files” contained all the same library/framework files as the SDK sample app does, then the ServiceFailed error disappeared. Maybe this hint helps others with the same issue.


That’s great to hear you were able to resolve this, and thanks for sharing the solution!

Please don’t hesitate to reach back out in a new topic with any additional questions. :slightly_smiling_face: