SDKAuth() does not trigger authcb

my demo project works perfect, after I integrate other feature, auth callback is never called.

let options={
authcb: onZoomAuthResult,
logincb: onZoomLoginResult,
logoutcb: onZoomLogoutResult
zoomObjs.authObj.SDKAuth(appkey, appsecret);
after these code, onZoomAuthResult should receive callback. But it’s never.

This issue only on Mac after I integrate other feature. So maybe it has conflict with some library. I want to debug deeply with set ‘enable_log=true’ in InitSDK(), but I can’t see more log even I set it as true.
I guess some of other package disables zoom sdk working.

we found the reason is signed zoom files. If I ignore do signature it works well. So please tell me how to deal with this issue on Mac.

Which version?

Hi guan_bj,

Thanks for the post. You may find the SDK log files in ~/Library/Logs/appName and if the crash happens, you may find the crash files in ~/Library/Logs/DiagnosticReports/(appName).

For mac SDK signing, the suggestions from Bella in this post could be helpful:Fall back : Mac create cpthost app failed


I think I’m seeing this exact same issue – it was working yesterday, but today I don’t see the authcb callback. I haven’t enabled or disabled signing at all.

Here’s a log file from a recent run:

Hi @vinay,

Thanks for the reply and the log file. Based on the provided info, it seems like the SDK authentication was successful and everything looks good from the log. Could you elaborate on the issue you are facing? Or you could refer to the implementation in the demo app:


I’m not able to start meetings. Here’s the code I used:

const ZOOMSDKMOD = require(nodeModDir)
const pos = nodeModDir.lastIndexOf('/')

const zoomSDK = ZOOMSDKMOD.ZoomSDK.getInstance({
  path: nodeModDir.substr(0, pos) + '/../build/Release/',
let res = zoomSDK.InitSDK({
  enable_log: true,
  langid: ZoomSDK_LANGUAGE_ID.Language_English,
  locale: ZoomAPPLocale.ZNSDK_App_Locale_Default,
console.log('ZOOM INIT SDK', res)
const zoomAuth = zoomSDK.GetAuth({
  authcb: (status: number) => {
    console.log('AUTHCB', status)
res = zoomAuth.AuthWithJwtToken(zoomSdkJwt)
const zoomMeeting = zoomSDK.GetMeeting()

console.log('AUTH WITH JWT', res)

const meetingOptions = {
    meetingnum: 10 // used my PMI
    zoomaccesstoken: zoomZakToken, 
    username: 'Place Holder',

  let ret = zoomMeeting.StartMeetingWithOutLogin(meetingOptions)

Here’s a log from the last run:

InitSDK 0

Corresponding run to that log (in case the last one was bad):

On tuesday, this worked fine. Yesterday, I started getting SDKERR_SERVICE_FAILED from StartMeetingWithOutLogin. I found this forum post Sdkerr_service_failed that seemed related. When I check in my app, my authcb callback never runs. I’ve run basically the identical code in the demo application and it works.

I fixed this.

Somehow, ZoomSDK.framework got corrupted – all the symlinks were missing. Copying the frameworks back over fixed it.

Hi @vinay,

Thanks for the reply and for the code snippet. Glad to hear that it is working for you now. We have tried to follow the info you provided but we are not able to experience the issue. Do you have any clues that how does the ZoomSDK.framework got corrupted?


Not yet – I’ll update this post once I figure it out, though!

Thanks! Looking forward to hearing from you.