Send Message Works with email, not with ID

I am receiving a 404 error when attempting to send messages to users using their ID. I am not receiving this error when using the user’s email. This is odd, as last week, ids as parameters worked perfectly. I have double checked that the id is correct, and have determined that the problem persists even when hitting the api endpoint from the zoom documentation site.

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Obtain a valid Zoom ID and email
  2. Attempt to send message with email as identifier for chat_user param, see message sends properly.
  3. Attempt to send message with the same user’s ID as the identifier for the chat_user param, receive 404 not found error.

I did some additional testing and was able to find the recipient using their user ID and the “Get a specific User” endpoint:{userId}
Still no luck sending a message to a User ID however.

Hi @luke.kendall,

Welcome to the Zoom Developer Forum.

Can you send us the payload that you are trying to send?


The body of the payload is simply {“message”:“Hello World!”}. The issue is with the query parameter. OAuth and the post body are working, the problem is that when using{{EMAIL}}

the endpoint works as expected, but when using{{USERID}}

The user cannot be found.
Documentation for the endpoint states that User Id and email can be used interchangeably.

Hey @luke.kendall,

We were able to reproduce the error. We will work on fixing this, for now please use the email to send IM messages. Jira: ZOOM-112638

You can get the email of a user by passing in their userId in the GET /users/userId endpoint.



Please let me know when an update has been made so that I can update our code base,


Hey @luke.kendall,

It looks like sending messages is only supported using the email. We will fix our docs.

Thanks for pointing this out, and sorry for the inconvenience.


1 Like

Thank you for the update

1 Like

Happy to help, and sorry again for the confusion!