User does not exist:

I was sending a request https://api.zoom.us/v2/users/XXXX/meetings to create a meeting but no matter what I passed as a user id (email, user id, or me) I keep getting User does not exist message. I called get user method and take user id from the response but still getting the same error message.

I am also facing the same issue .

I’m also having the same problem.

Hey @PasinduDew, @samson, @ahaile,

Can you please message me the userID you are passing in?

Thanks,
Tommy

Hi Tommy,

Thank you for the response. I used below IDs and Emails and got the same response.

“id”: “5ZM5eN_pRCuxOkUMbk46FA”
“email”: “ahaile@yehulum.com

“id”: “r7c6lnaATKu5oH8G_P6zNw”
“email”: “ante21et@gmail.com

Thankd you,
Anteneh

I’m also getting the same error every time I try.

Are you guys using a JWT or account-level OAuth app?

Hi @ahaile,

Are these users underneath your account?

@samly - Thanks for helping out! :grinning:

Hi Michael,
Yes those users are mine.

Hey @ahaile, @msembijoseph4,

Are you using JWT or OAuth? If OAuth, what is the name of your App?

Can you also share your request body JSON?

Once I know this, I can investigate further. :slight_smile:

Thanks,
Tommy

Hi @ahaile cc @Michael_Purnell and @tommy
I had the same problem, and I think it was because my users didn’t yet have confirmed emails. I used the custCreate method instead and that fixed the problem.

1 Like

Thanks for the update @lucas.cioffi! :slight_smile:

Glad you got it working!

-Tommy

Here’s the source code …
curl --location --request POST ‘https://api.zoom.us/v2/users/c6f-redacted9A/meetings
–header ‘Content-Type: application/json’
–header ‘Authorization: Bearer redacted’
–data-raw ‘{
“topic”: “Test API Meeting”,
“type”: 2,
“start_time”: “2020-06-15T08:00:00”,
“duration”: 60,
“schedule_for”: “string”,
“timezone”: “America/Los_Angeles”,
“password”: “8789e3”,
“agenda”: “My agenda goes here”
},
“settings”: {
“host_video”: true,
“participant_video”: true,
“cn_meeting”: false,
“in_meeting”: false,
“join_before_host”: false,
“mute_upon_entry”: false,
“watermark”: false,
“use_pmi”: false,
“approval_type”: 2,
“registration_type”: 1,
“audio”: “both”,
“auto_recording”: “none”,
“alternative_hosts”: “none”,
“close_registration”: true,
“waiting_room”: true,
“contact_name”: “MLD Foundation”,
“contact_email”: “zoom@MLDfoundation.org”,
“registrants_email_notification”: true
}
}’

Hey @OregonDean,

Please try without setting the schedule_for property.

Thanks,
Tommy

1 Like