`sendAppInvitation` API fails with participant UUID as parameter(s)


I think this may be a bug with the sendAppInvitation API;

We call the method with a user_list containing participantUUID, but receive an error saying that participantId is deprectated. See our app’s logs with explanation:

Any ideas? @evgeny.balashov



Also, I tried it using the actual participantId and that fails, too. So it may just be a bug with the validation of the parameters? :thinking:

This is an issue on our end. We are working to fix it in the SDK and the client.

Until then, I’ve tried the following two workarounds successfully in

  1. user_UUID_list: [“ABCDEF01-01234-01234-01234-ABCDEF012345”]
    undocumented, participantUUID
  2. user_list: [“12345678”]
    participantID, shows a warning that it’s deprecated that has very similar text to the error

We are tracking this issue, thank you for your patience.

1 Like

Thanks @Robert.Wallis. Much appreciated

1 Like

Hey @Robert.Wallis, is this bug fix going to be included in the June release?

We’re super excited to use Guest mode and we want to use this API to make it seamless to invite Guests to the app! We are likely going to use the workaround suggested, but want to confirm whether it’ll work on the latest client

Oliver have you looked into using the new version of the Zoom Apps SDK? Resources are here, in this thread:

Hey @JonStewart , we just upgraded to use v0.16.0 via the npm package today

The bug still exists, but the workaround using user_UUID_list works great for now!

Would appreciate if you could let us all know if/when this does get fixed, so we can migrate to user_list parameter

Oh no, the docs say that ZoomSdk | @zoom/appssdk - v0.16.0

zoomSdk.sendAppInvitation({ participantUUIDs: [participantUUID1, participantUUID2, ...],});

sendAppInvitation uses a new parameter called participantUUIDs, are you using this and still getting an error or are you using:

zoomSdk.callZoomApi("sendAppInvitation", ...)

Note that callZoomApi is being deprecated.

1 Like

Ah, brilliant! Thanks @Robert.Wallis. I’ll reference that set of documentation from now on. Looks great

1 Like