Server to server oAuth Application - grant_type "account_credentials" error

I’m dealing with an issue when trying to generate a bearer token using a server-to-server oAuth app. I’m sending the information across using the grant_type “account_credentials” but getting response

{“reason”:“unsupported grant type”,“error”:“unsupported_grant_type”}",

If I use the grant_type of “client_credentials”, I am able to generate a bearer token yet when I try to use that token on an api endpoint, I get the similar grant_type error as above.

I also tried using the core curl sample provided in the docs (

curl -X POST -d ‘grant_type=account_credentials’ -d ‘account_id={accountID}’ -H ‘Host:’ -H ‘Authorization: Basic Base64Encoded(clientId:clientSecret)’

and still got the “unsupported grant type” error…
Has anyone experienced this as well?
Could another bad setting like incorrect encoded client:secret cause that error?
At a loss…

Stupid developer (me)
App created was the wrong type. I thought I made a “Server-To-Server oAuth” app but instead just a standard oAuth…once I created the right type, it worked…
Apologies all…learn from me :oP

1 Like