Set password on meeting - create meeting REST API

Using the create meeting API, I can’t create a password-protected meeting for users in my account. I can set a password on my own meetings. I use the same endpoint to generate meetings for dozens of users, and all works well, except for setting a meeting password.

No password set on meetings created via API.

JWT auth

Create Meeting Endpoint

Body of POST to create meeting:
topic = “meetingName”,
type = 2,
start_time = “2020-05-20T07:15:00Z”,
duration = 60,
timezone = “America/Los_Angeles”,
password = “1234567890”,
alternative_hosts = “”,
settings = new {
auto_recording = “cloud”

Additional context
I’ve tried different admin settings on the account, including “Require password when creating new meeting” and “Embed password in invite link”, but no help.
Also tried adding myself as an alternative host.

thanks for any help here-

Hey @pkreemer,

Can you share the response body / error when making the request to set a password?