Question about the API endpoint "Create a meeting"


We want to use the API to create a meeting.

In the default_password section of the API documentation, we found the following:

If this value is true and the user has the PMI setting enabled with a password, then the user’s meetings will use the PMI password. It will not use a default password.

However, when I tried it with my Zoom account, I saw a different behavior.
When I POSTed a request with a pre-set PMI password and the default_password parameter set to true, a random password was generated. This is inconsistent with the above statement.


No error observed.

Which App Type (OAuth / Chatbot / JWT / Webhook)?


Which Endpoint/s?{userId}/meetings

How To Reproduce (If applicable)

Send a POST request to the endpoint above.

Request body:

{"topic": null,
 "start_time": "2022-01-31T09:30:00Z",
 "duration": 30,
 "timezone": "Asia/Tokyo",
 "default_password": "true"}

Response body:

	"uuid": "*******",
	"id": "***********",
	"host_id": "****",
	"host_email": "",
	"topic": "Zoom Meeting",
	"type": 2,
	"status": "waiting",
	"start_time": "2022-01-31T09:30:00Z",
	"duration": 30,
	"timezone": "Asia/Tokyo",
	"created_at": "2022-01-31T08:52:54Z",
	"start_url": "***********?zak=***********",
	"join_url": "***********",
	"password": "******",
	"pstn_password": "******",
	"encrypted_password": "************",
	"settings": {
		"host_video": false,
		"participant_video": false,
		"cn_meeting": false,
		"in_meeting": false,
		"join_before_host": false,
		"jbh_time": 0,
		"mute_upon_entry": false,
		"watermark": false,
		"use_pmi": false,
		"approval_type": 2,
		"audio": "voip",
		"auto_recording": "none",
		"enforce_login": false,
		"enforce_login_domains": "",
		"alternative_hosts": "",
		"close_registration": false,
		"show_share_button": false,
		"allow_multiple_devices": false,
		"registrants_confirmation_email": true,
		"waiting_room": true,
		"request_permission_to_unmute_participants": false,
		"registrants_email_notification": true,
		"meeting_authentication": false,
		"encryption_type": "enhanced_encryption",
		"approved_or_denied_countries_or_regions": {
			"enable": false
		"breakout_room": {
			"enable": false
		"alternative_hosts_email_notification": true,
		"device_testing": false,
		"focus_mode": false,
		"private_meeting": false,
		"email_notification": true
	"pre_schedule": false

Hi @k-hosoki ,

Did you have this setting when you did “create a meeting”?

If not, it will be creating a meeting with a new non-PMI meeting id even if the account has PMI enabled on the web portal. Did the default password populate for this meetings?

Thank you,

1 Like

Hi @gianni.zoom ,

Thank you for your answer.

My question was not a good one and it seems that my intention was not conveyed correctly.

We are fine as long as it is guaranteed that a random password will be generated (without PMI password being set or no password) if use_pmi is not specified.
Am I correct in understanding that if both use_pmi and password are not specified, and default_password is set to true, then a non-PMI meeting will be created with a random password generated according to the user’s password requirements?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.