Creating Multiple meetings in the same day Error

Hello,

I’ve created 2 meetings via API for a Licensed user.

Some how, both meetings created for the user, the start URL was using her her own Personal Meeting ID instead of creating a new meeting URL for her. And this updated her personal meeting password to the 2nd meeting’s password.
E.g.
1st Meeting:
Zoom Response ID: 11111111
Start URL: {Zoom URL}/j/88888888
Password: 123456
Date time: 27/9/2020 9am

2nd Meeting:
Zoom Response ID: 22222222
Start URL: {Zoom URL}/j/88888888
Password: 654321
Date time: 27/9/2020 4pm

So what happened now, our users of the first meeting cannot join since the password was changed and we didn’t realized it until the meeting started.

We create about hundreds of meetings like this on a weekly basis via API, and this only happened for this user.

Do you know the issue is? How can we prevent this in future?

We are using JWT to connect with the API.
Endpoint: POST {Zoom API URL}/users/{userId}/meetings

Should I share the Zoom response UUID here too?
Not sure it’s safe to do so.

Thanks!

Hey @jay.li

Thanks for posting on the Zoom Devforum! I am still learning, but I will try my best to help answer your question. :slightly_smiling_face:

Checkout these related threads that may have the answer you are looking for:

If these threads did not help, please let us know by replying back here and someone from the Developer Relations team will get back to you shortly.

Thanks,
DeveloperBot

Nope, these topics didn’t help with the issue.

Hey @jay.li,

Is it possible to share the full request URL/body of your request(s) to create these meetings that used the hosts PMI ID? It would be helpful to take a closer look at the meeting type and settings to make sure this isn’t the result of an unintentional setting.

If you could provide the meeting UUIDs as well, this would be helpful.

Thanks!
Will

Hi Will,

We create all our other meetings the same way with the same parameters.

Only this user’s meeting created that day was under her own personal meeting URL.

The rest are created with a new unique meeting ID.

Here’s the POST URL that we use to create the meetings for this user.

https://api.zoom.us/v2/users/{{email}} /meetings

Request Body:

{

“topic”: “{{topic}}”,

“type”: 2,

“start_time”: “{{start_time}}”,

“duration”: 120,

“timezone”: “Asia/Singapore”,

“password”: “{{password}}”,

“agenda”: “{{topic}}”,

“settings”: {

“mute_upon_entry”: true

}

}

First API Call:

“uuid”:“7MuX1+8XSXKtUdG4kifsUQ==”,“id”:92807411155

Second API Call:

“uuid”:“7MuX1+8XSXKtUdG4kifsUQ==”,“id”:92909633415

Seems like the UUID are the same, but the ID is different for both meetings.

Thanks!

Regards,

Jay

Hey @jay.li,

Thanks so much for providing those details!

In taking a closer look, it sounds like this user probably has the “Use Personal Meeting ID (PMI) when scheduling a meeting” setting set to true, which would cause this behavior.

If you have a chance, I recommend reading this thread:

Let me know if this helps to clear things up!

Best,
Will

Hi Will,

Thank a lot for helping us identify the issue.

I see there are some options in the user group settings to disable this.

So if we want a new meeting ID to be created every time for our users regardless of their account setting, we need to disable and lock this 3 settings?

Or just disable and lock the “Use Personal Meeting ID (PMI) when scheduling a meeting” is enough?

<img width=“747” height=“327” style=“width:7.7812in;height:3.4062in” id=“Picture_x0020_3” src="//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/business6/uploads/zoomdeveloper/original/3X/2/9/2968b5542d8ced32ccbb9b429cc8aeea923bb887.png" alt="Graphical user interface, text, application

Description automatically generated">

Thanks!

Regards,

Jay

Hey @jay.li,

Disabling this setting (Use Personal Meeting ID (PMI) when scheduling a meeting" on this user should ensure that a new, unique Meeting ID is generated when you create a meeting for them via API.

Let me know if you still have any questions about this!

Best,
Will

Hi Will,

Ok noted. Will try disabling that setting.

Thanks!

Regards,

Jay

No problem, happy to have helped clarify!

Best,
Will

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.