Setting Area Code for Phone User

Hey there

Is this a bug or I’m doing it incorrectly?

I’ve found if I want to set the area_code eg

https://api.zoom.us/v2/phone/users/<User_ID>/settings
[
    'area_code' => '08',
    'outbound_caller_id' => '',
]

This does not set the area_code.

If I go in the UI and set one for this user, then I can update it to something else, but don’t appear to be able to set it if not already set to a value.

Thanks, Alex

Hi Alex,

This issue should be fixed in our May update which is scheduled to roll out this weekend. After that release, the API will allow setting area code for all users, including those without existing value.

ah awesome!

Thank you

Thanks for sharing this solution.