I am attempting to present the Zoom meeting UI using the MobileRTCMeetingService`s showMobileRTCMeeting. However, the completion handler never gets called and the method returns NO. What are the use cases when this method returns NO?

I am using an instance of MobileRTCMeetingStartParam4WithoutLoginUser to start the meeting.

Which version?

Smartphone (please complete the following information):

  • Device: iPad Pro
  • OS: iOS 12.4.1


Hi Xiao,

Thanks for the post. Are you trying to use the Zoom default UI? The completion handler will not invoke if the method returns NO. Under the following cases, this method will return NO:

  • SDK has not been initialized successfully
  • Not in a meeting
  • The root controller has been changed

You may also refer to the reference below:

 @brief Set to show UI of meeting.
 @param completion User can do other operations once the meeting UI comes out.
 @return YES means that the method is called successfully, otherwise not.
 @warning The method does not work if you have set mobileRTCRootController via [MobileRTC setMobileRTCRootController]
- (BOOL)showMobileRTCMeeting:(void (^_Nonnull)(void))completion;

Hope this helps. Thanks!

1 Like

Hi Carson,

Thanks for the additional info - that helps a lot!

One other question - are there any issues if we use custom UI in one part of the app and non-custom UI in another part of the app?


Hi Xiao,

Thanks for the reply. Mmm…It really depends on how you mix the custom UI and the Zoom UI. If you would like to use the non-custom/Zoom UI component with custom UI(such as using the Zoom UI’s participant’s list, chat, etc.), it should work just fine, our demo app also have this implementation. If you are trying to mix them in other ways, we have not tried those and there are no precedents or any info on this.

Hope this helps. Thanks!

Hey Carson,

This is not exactly related to showMobileRTCMeeting but am seeing the same error. What if we get the same error, MobileRTCMeetError_Unknown, but inside onMeetingError delegate method? Is the same 3 cases as above?

The thing is, when we called startMeetingWithStartParam, it was a success and the meeting starts. But almost immediately after, we get the callback with that error status inside onMeetingError.

David Moe

Hi David,

Thanks for the post. No, the MobileRTCMeetError_Unknown returned in the onMeetingError usually means the network might have an issue or an unexpected problem is happening. Could you provide more information on this? Are you getting other error messages?


Hey Carson,

Sure, this is the flow of the call order:

  • startMeetingWithStartParam returns successfully
  • onMeetingStateChange delegate method called with the status MobileRTCMeetingState_Connecting
  • onMeetingError delegate method called. The error is MobileRTCMeetError_Unknown and the message is “the meeting has problem. (Error code: 1001)”


Hi David
I can’t to reproduce the problem.
You can try it with the latest version of the SDK.
If you have any questions, please ask here.

Hi David

I tried the version: 4.3.47351.0514 again

can not reproduce the issue too.

Hey Murray,

Thanks for trying it out. I should’ve mentioned that this doesn’t happen to every account, only a few certain ones. But when it happens, we don’t really know the reason why it happens. Would we be get more information about the error somehow?


Hey David

I have consulted our colleagues at web and learned that code=1001 means that the user does not exist. Users may have been deleted or disabled

1 Like

Thanks Murray, we will look into why users are being deleted or being disabled.

Thanks Murray!

Let us know if you have any other questions! :slight_smile: