Team Chat App - returning "Account does not enabled REST API."

API Endpoint(s) and/or Zoom API Event(s){userId}

I am OAuthing using team chat app against with grant_type=client_credentials.
I am using client id and client secret of my chat app. I retrieve the bearer token and pass it to{userId} intending to receive the user’s info. Error response shown below.

I have added /user:read:admin scope to my app and confirmed that my user (which the app is under) has developer role/permissions. Note that I am passing my own userId.

“code”: 200,
“message”: “Account does not enabled REST API.”

I resolved this by creating another app server-to-server app and nesting in my chat app.
Requires{account_id} where account id is the app’s account id, and use the server to server client id and secret for basic auth.
I confirmed that my account (where the app is built under) has read user info privileges and also assigned “/user:read:admin” scope to the server-to-server app.

This generated a token that can be used with GET and successfully get user info.

Unfortunately, was not able to resolve this using only chat app client credentials with same scope applied. This needs to be better documented in Zoom APIs docs and App docs as having the scope optional but not work does not make sense.