200 - Account does not enabled REST API

A Chat Bot has been setup and seems to be setup correctly.
Trying to setup to send chats which requires getting the ID to use to send the chat.


I’ve searched the Forum & none of them help to resolve this issue in both PostMan and in the QuickBase Pipeline Make Request.
Account ID: 7001337182

Hi @gfigueroa
Thanks for reaching out to the Zoom Developer Forum and welcome to our community! I am happy to help here!

What is the exact issue you are facing? are you trying to get the user ID ? or are you refering to the to_jid?

Thanks for responding Elisa!

I want to send chat to either a person or channel. If I read correctly I can’t use their email but instead the jid.

I set up a chat bot and a server-to-server which seem to be correct as both can be refreshed to get a new token.

When I try to use the api to pass my email id to get the jid (using either the Chat or StoS token) then the Account does not enabled REST API appears.

This happened 1st w/ the chat bot but after reading some other post he said that he had to setup a server to server to get the API to return the jid.

Both of them have /user:read:admin and the /user:write:admin

Well I’ve got the Server-to Server to give an access token that can be used to get the jid.
this link helped:
Internal apps (Server-to-server) (zoom.us)

Now the problem is that the chat message fails with the below:
“code”: 7004,
“message”: “No channel or user can be found with the given to_jid.”,
“result”: false

Can’t seem to send 1st Zoom msg from our app.
The Tokens refresh fine

This is the Chat Bot scope settings.

Hi @gfigueroa
Sorry for the late reply here, I did not get a notification on my end about the updates you made on this thread.

If you want to send messages using a chatbot, please make sure that you are working with the credentials associated to a Team Chat app and not a Server to Server oauth app

Thanks, Elisa, I’ve tried everything and the only thing I can think of is that I am using the wrong Account ID.

I took our actual Account ID and converted to base 64 but I’d noticed that the Server to Server had a different Account ID base 64.

I tried that one too but still failed.

How do I find the Account ID for the Team Chat, I;ve looked but not found anything.

Hi @gfigueroa
Sorry to hear that you are having issues
Can you please try using the client ID and client secret from your team chat app and convert those to base 64 and pass that as an access token when making the request?

Here is a sample app that might help you as a guide

I tried the base 64 client ID/Secret w/ a colon & no space between them w/ the following result;
“code”: 7010,
“message”: “Invalid authorization token.”,
“result”: false

Any other Account ID that is used other than the main Zoom Account ID (encoded in Base 64) gets the following:
message:“Not authorized.”

As stated before, both the Chat & ServertoServer tokens can successfully be refreshed.

To be clear, all that is attempted is to determine anyone’s JID & then send that person a simple msg.
Currently trying in PostMan but eventually will be sending from various QuickBase (Lo Code/No Code) application(s).
QuickBase can be an event driven application so if certain conditions arise then a msg needs to be sent out.
For instance if the COO of the company opens a ticket then that is of HIGH importance and would send a Zoom msg to the IT Mgr.

QuickBase is currently doing this in WebEx & has done it in MS Teams, currently our company is transitioning to Zoom.

I don’t understand why this does not work especially since I have accomplished getting the jid successfully using the ServertoServer Oauth Access Token & the get_users API command.
Reading this link to get the jid further affirms the processes that have been setup are following that link’s process.

Actually getting a 403 error code:

Can you double-check that the user_jid is also being passed with the body to chat/messages?

No, user_jid is not being passed.
I’d read about user_jid but what I read does not show that item is needed.

Its failing with a 403 in using user_jid or just to_jid.

Please try passing the body with it - as I believe it is required.

Also, if you could pass the info you read about user_jid not being required, I would like to double-check it for accuracy.