Unable to build SDK for simulator (M1 mac) - even sample project

As I moved to the new M1 mac I was trying to run my app with MobileRTC on the simulator. I’ve got the newest SDK taken from Marketplace and tried to compile but a lot of Undefined symbols for architecture arm64 occurred.
I tried to run your sample app on the simulator - but also it failed with a lot of errors.

Which iOS Meeting SDK version?

To Reproduce(If applicable)

  1. Be on M1 Mac
  2. Download new SDK, open MobileRTCSample
  3. Insert all missing keys, whatever
  4. Try to run on simulator


Please, help :slight_smile:

Hey @dominik.majda,

Thanks for using the dev forum!

The SDK does not yet support running on simulator on an M1 mac. Can you try a physical device?


Hi @Michael_Condon.

Thank you for the quick response. Of course, it works on the real device but it will be a real pain developing across devices I don’t own.

Is there any chance this will be addressed soon?

Hey @dominik.majda,

I totally understand. It is on our roadmap to provide support for this, but we do not yet have an ETA at this point.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.