Unable to create meeting with ZAK

Description
Our company is developing an application that is using Meeting SDK to interact with Zoom.
Now we need to use a ZAK token to create an instant meeting.
We successfully obtain a ZAK token from the server, however meeting creation fails.
To start the meeting, we are calling the [meetingService startMeetingWithZAK:].
The ZAK elements we pass to this method has following fields:
userType - we have tried the SDKUserType_APIUser which leads to the “ZoomSDKError_WrongUsage” error. With any other value we are able to get “ZoomSDKError_Success”
displayName - We pass the non-empty string here.
userId - “me” or the user identifier we obtain from the backend.
displayID - 0
participantId - 0
isDirectShare - NO
isNoVideo - NO
meetingNumber - 0
isNoAuido - NO
vanityID - nil
zak - ZAK token we obtained from the backend

With these parameters we get “ZoomSDKError_Success” when calling the “startMeetingWithZAK:”, however the meeting does not start.
we get the “onMeetingStatusChange:” call with:
state = ZoomSDKMeetingStatus_Failed
error = ZoomSDKMeetingError_Unknown
reason = EndMeetingReason_None

I assume some parameter values are wrong. Can you please suggest what is the correct way to create an instant meeting with ZAK?

Which macOS Meeting SDK version?
5.5.12511.0420

Device:

  • Device: iMac late 2017
  • OS: macOS Big Sur 11.4

please provide link of your company

Hi @mcfly, thanks for the post.

I believe this issue is due to the userType param having an incorrect type specified. Instead of SDKUserType, can you try using ZoomSDKUserType_WithoutLogin? I know that this will produce a warning (which we will work on fixing), but this may resolve the issue.

I’ll also keep this thread updated with any additional information on fixing this param as we look into it.

Thanks!

Hi @jon.lieblich , we have tried this, but unfortunately the issue still persists. Do you have any other suggestions?

Hi @mcfly,

After following up on this, we may have found the issue. When you specify that it is an API user, is that because this is a user created through the createUsers REST API? If so, this is a limitation imposed by the back end since these types of users can only start meetings scheduled through the REST API.

Thanks!

Hi @jon.lieblich ,
The user was created with email/password, not via API.
We tried to specify all possible user types. API option gives immediate failure, other options give ZoomSDKMeetingStatus_Failed after status “Connecting”

Hi @mcfly,

Thanks for confirming. The API user type is really only intended to be used for users who were created through the REST API, since that type of user will be limited in what they can do.

Since the error codes you are seeing are vague, it isn’t obvious what could be causing this. Let’s try to rule out some variables to see if we can narrow it down a little. First off, can you try updating to the latest version of the SDK and retesting? If the issue is still present there, is this reproducible in the SDK sample app (using the latest version as well)?

Thanks!

Hi @jon.lieblich ,
Thank you, your suggestions were very helpful. We have found a problem on our side. The issue was that previously we have enabled auto-login in SDK and ZAK does not work at all if the user is logged in in SDK.
After fixing this, everything started working even on the old SDK version.
Thank you again!

That’s great to hear you were able to resolve this!

Please don’t hesitate to reach back out in a new topic with any additional questions. :slightly_smiling_face: