Unable to delete meetings with meeting:write scope


#1

I’m trying to delete a meeting using the following API call but an error comes back about missing scopes. This is for an app created through the marketplace management section.

https://api.zoom.us/v2/users/<myUserID>/meetings/<meetingID>

{“code”:124,“message”:“Invalid access token, does not contain scopes: [user:write:admin]”}

 

I also tried https://api.zoom.us/v2/users/me/meetings/<meetingID>, but that didn’t work either.

According to the permissions at https://devdocs.zoom.us/docs/permissions the meeting:write scope should be enough to delete the meeting. This meeting was created using the API, but I’m unable to delete the same meeting through the API.

Is this a bug in the API or is the documentation incorrect?

 

EDIT: I’m also encountering the same error updating an existing meeting with PATCH.


#2

Hi Kent, 

What scopes does your app currently have and is your app an account level app or user level app?

Thanks


#3

The requested scopes are user:read and meeting:write. The app is created on the marketplace, so I think that means it’s a user-level app.


#4

Hi Kent, 

If the error is reporting back  user:write:admin  that is most likely an account level app and not user. With meeting:write you should be able to delete your own meetings. If you are using the /me/ API, this will be associated with the account owners meetings only.

Would you be able to share the name of the app and account ID so that I can take a closer look? 

Thanks


#5

The development client ID is 29d1adQ0ST2XIkRzloQjQ under this account (on the App Marketplace). I don’t see anywhere listed on the app description whether it is a client or account level app, but I thought it was a client app.

To verify I created a new app as a client app (development client ID: Wc0vVR9QXK6m0ArxaCGlQ) and it’s returning the same error.

 

Thanks!


#6

Hi Kent, 

I was unable to reproduce an error on my end. Since your app is account level you should use the /me/ API with a meeting that is tied to your account. Earlier, you stated that you tried https://api.zoom.us/v2/users/me/meetings/<meetingID, what was the error that you received?

Thanks


#7

I receive the same error as using <myUserID> in the URL. I just tried the following request:

PATCH - https://api.zoom.us/v2/users/me/meetings/970962087

{“timezone”:“America/Chicago”,“topic”:“Test123”,“start_time”:“2018-09-26T10:00:00”,“duration”:60}

 

This was the result:

{“code”:124,“message”:“Invalid access token, does not contain scopes: [user:write:admin, user:write]”}

 

Thanks!


#8

Hi Keith, 

Can you try choosing the user:write scope within your app in marketplace? 


#9

I added the user:write scope and reauthenticated, but now I receive a 403 error.

DELETE or PATCH: https://api.zoom.us/v2/users/me/meetings/300899503

x-zm-trackingid: WEB_128657a3ebf04022b29ef0a3d9adecda

The content of the response is a web page that says 403 Forbidden in the content.


#10

Hi Kent, 

Please use  /v2/meetings/{meetingid} instead as we dont have v2/users/me/meetings/{meeting-id}.

Thanks


#11

That was it, thank you for pointing out my stupid mistake! Now that I see it it’s obvious :slight_smile: