Unable to find explicit activity class {us.zoom.sdkexample2/com.zipow.videobox.LoginActivity}

I am playing around with the Android sample project but I am encountering a crash when after I click sign in.

android.content.ActivityNotFoundException: Unable to find explicit activity class {us.zoom.sdkexample2/com.zipow.videobox.LoginActivity}; have you declared this activity in your AndroidManifest.xml?

Steps to reproduce the behavior:

  1. Run the app
  2. Join a webinar that requires registration
  3. Click Sign In
  4. Crash

Android 9

Multiple Emulators running Android 10+

Hi @andrew.joyce, thanks for using our SDK.

As of v5.9.0, the SDK no longer allows you to directly log in, so this option should not be available. I’ve tried testing the sample app, but I’m not seeing a login option when registration is required for the webinar I’m joining. Can you please provide a video of the behavior you are seeing so that we can look into this further?


Hi Jon,

Thanks for getting back to me. That’s strange. If I try and join a Webinar without registering then I get the following pop up

After clicking “Sign In” the app crashes

Hi @andrew.joyce,

Can you try clearing the app’s cache/data, uninstalling from your device, and reinstalling?


Hi @jon.zoom

I have tried that but still shows the same thing. I tried the demo project and that also displays the Sign In option.

Here is a video of the issue. This is from the example2 project using the latest SDK version (v5.9.3.4273)

Hi @andrew.joyce,

Thanks for providing that video. We are definitely taking the same steps to reproduce this, but I’m not seeing the same results. Have you made any changes to the sample app?


Hey @jon.zoom

I just downloaded and ran a fresh version of the example project and I am still running into the issue. Could it be because It’s a webinar and not a meeting?


Is there anything in the SDK that allows us to hide the Sign In option?

Hi @andrew.joyce,

Thanks for trying with a fresh copy of the project.

Could it be because It’s a webinar and not a meeting?

When I tested this, it was with a webinar and I did not see the same behavior. There must be something else happening here, but it isn’t clear what it is yet. Can you provide the SDK logs so that we can investigate further? The encrypted logs can be found under sdcard/Android/data/${PACKAGE_NAME}/logs. The log files will be stored there, along was a last_log_file_id.txt file indicating which file was generated on the most recent use of the SDK.

Is there anything in the SDK that allows us to hide the Sign In option?

There is no option for this, because as far as the SDK is concerned, this functionality does not exist.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.