Unable to join a meeting with a sample app from Web SDK

I am attempting to follow the Zoom WebSDK tutorial and running into intractable issues.

I cloned the repo and created a JWT application. From there I generated an API key and secret and replaced appropriate stubs in the CDN/js/index.js. I then started the application. The browser came up, I entered my name and the meeting id (that I previously started). I removed the dashes to leave the number only. I tried to Join but it failed:


In the error handler, this was the response: {method: "join", status: false, errorCode: 1, errorMessage: "joining fail", result: null}

I thought that maybe I should have created an SDK app instead of JWT, so I then repeated the entire process with SDK credentials. Same exact result.

I also tried using random meeting numbers - which resulted in the same exact error.
I’ve also tried uncommenting various version of ZoomMtg.setZoomJSLib call (or commenting it out all together) - also didn’t work.

I am the owner of the account and under User Management/Role Management/Zoom for developers both View and Edit options are on. My account is licensed.

What am I missing???

Which version?
I am assuming 1.7 is what’s on github.

Additional context
I am using Windows 10.

Hey @matthew1, happy to help hear!

Are you passing in a real meeting ID that has been started?