Web SDK "joining fail"

Description
Hi.
I cannot join meeting room.
I’m a free trial user since yesterday.
I just installed and modified my api key/secret in the ‘index.js’ as the instruction( https://zoom.github.io/sample-app-web/index.html ).
It does not work.
I’m in South Korea not China.

I tried to use different meeting ID created by other accounts.
One was “9094795653” and the other one was “5766770040”.
I have already read other guys’ questions and answers.
In my case, it was not helpful.
Thanks in advance.

Error

  1. {method: “join”, status: false, errorCode: 1, errorMessage: “joining fail”, result: null}

  2. method: “join”

  3. status: false

  4. errorCode: 1

  5. errorMessage: “joining fail”

  6. result: null

  7. proto: Object

Which version?
1.7.0

Screenshots

PC (please complete the following information):

  • Browser: Chrome

my index.js is like below

    (function(){

	console.log('checkSystemRequirements');
	console.log(JSON.stringify(ZoomMtg.checkSystemRequirements()));

    ZoomMtg.setZoomJSLib('https://source.zoom.us/1.7.0/lib', '/av'); // CDN version default
    ZoomMtg.preLoadWasm();
    ZoomMtg.prepareJssdk();
    
    //key is masked for here.
    var API_KEY = '**********';
    var API_SECRET = '***********';


    document.getElementById('join_meeting').addEventListener('click', function(e){
        e.preventDefault();

        if(!this.form.checkValidity()){
            alert("Enter Name and Meeting Number");
            return false;
        }

        var meetConfig = {
            apiKey: API_KEY,
            apiSecret: API_SECRET,
            meetingNumber: parseInt(document.getElementById('meeting_number').value),
            userName: document.getElementById('display_name').value,
            passWord: "",
            leaveUrl: "https://zoom.us",
            role: 0
        };


        var signature = ZoomMtg.generateSignature({
            meetingNumber: meetConfig.meetingNumber,
            apiKey: meetConfig.apiKey,
            apiSecret: meetConfig.apiSecret,
            role: meetConfig.role,
            success: function(res){
                console.log(res.result);
            }
        });

        ZoomMtg.init({
            leaveUrl: 'http://www.zoom.us',
            isSupportAV: true,
            success: function () {
                ZoomMtg.join(
                    {
                        meetingNumber: meetConfig.meetingNumber,
                        userName: meetConfig.userName,
                        signature: signature,
                        apiKey: meetConfig.apiKey,
                        userEmail: 'testuser@naver.com',
                        passWord: meetConfig.passWord,
                        success: function(res){
                            $('#nav-tool').hide();
                            console.log('join meeting success');
                        },
                        error: function(res) {
                            console.log(res);
                        }
                    }
                );
            },
            error: function(res) {
                console.log(res);
            }
        });

    });

})();

Hey @Hongsik_Alex_Lee, thanks for posting and using Zoom!

To confirm you are using the Key and Secret from a JWT app?

Thanks,
Tommy

Of course, I got api key and secret from JWT.

Hey @Hongsik_Alex_Lee,

Thanks for confirming.

If you are trying to join a meeting with a passWord, make sure to add that passWord to the meetConfig object.

Also make sure the meeting you are trying to join allows users from any domain, and do not have to be signed in.

Thanks,
Tommy

Hello

  I am getting the same problem Joining meeting timeout. Joining failed. 

I have followed the exact instructions on the below link(Even used my API key and Secret key)

https://marketplace.zoom.us/docs/sdk/native-sdks/web/reference

Screen Shot 2020-03-17 at 6.27.10 PM

As per the instructions, it says “Enter a Name and the Meeting Number of meeting you started. Click Join.”

But I am not sure which meeting number I have started. I am just putting any random numbers. I am also getting “WebSDK1.7.2#CDN” in the name field.

Appreciate if someone can tell what I am missing here.

Thx

Hey @stalliongroupllc9, thanks for posting and using Zoom!

You must use a real meeting number, or else you will get that error.

You can create a meeting and get a meeting number here.

Thanks,
Tommy

Thanks a lot tommy. It means that host needs to schedule the meeting, get the real meeting id and then start the meeting as well.

If you try to join before starting the meeting then it gets the error that “meeting hasn’t started yet”.

Thanks a lot again. It worked for me.

2 Likes

Happy to hear you got it working! :slight_smile:

-Tommy

Hi @tommy,

I am having the same issue where i am not able to join a public meeting of another user through my web SDK. However I am able to join the meeting by clicking the meeting link they sent
zoom.us/j/{meeting number}

might you have a suggestion why this is happening in my webSDK when I am able to join meetings that i have created on my own account?

Hey @rcptfit, thanks for posting and using Zoom!

Please provide the error message, code, and steps to reproduce the issue.

Thanks,
Tommy

hey [stalliongroupllc9]

Just to be sure,
THe meeting id is the meeting number but without the “-”?

Hey @chavindmungun014, thanks for posting and using Zoom!

Correct!

-Tommy

Hi. Tommy.
I Followed the instructions given to stelliongroupllc9.
I schedulled a meeting. Started the meeting. Use the meeting id but still had the same error.

Thanks. working now.

1 Like

Happy to hear it is working now @nanakofiofori! :slight_smile:

Do you mind sharing the solution?

Thanks,
Tommy

Cloned the sample app and i’ve been getting the same errors described above. Is there a specific solution here?

Hey @kameron.robinson,

Make sure you are using a real meeting number, and a JWT App Type for the API key and secret.

Thanks,
Tommy

Yupp that was the solution thank you!

One more question regarding peer dependencies. It’s unclear if we need to install all peer dependencies (jquery, etc.) as well when installing the @zoomus/websdk.

1 Like

Glad that fixed it! :slight_smile:

When installing via NPM, the sub dependencies are installed for you, you just have to make jQuery and the lib file globally accessible to your app.

node_modules/@zoomus/websdk/dist/lib/

Thanks,
Tommy

@tommy I am facing a similar issue but for Webinar. I am able to join regular meetings without issues. I am using the correct Webinar ID and the correct JWT API key & Secret Key.