Unable to join meeting ionic app

Hi,

I am unable to join meeting from the app running ionic SDK for last two days.

It was working fine till Saturday.

Now after clicking join meeting. It start showing preparing meeting page.
Then i get success message and it comes back to join meeting page .

Unable to join the meeting.

Please check the issue.

Hi @bhamra ,

There was a minimum version requirement implemented on 12 august 2022, which requires developers to update their meeting SDK to minimally 5.4 and above. Any version below 5.4 will not be able to join meetings.

I couldn’t find any update for ionic.

1 Like

ionic is no longer actively supported

3 Likes

Its [email redacted]
Please share

3 Likes

Hello Chung!

Could you please share it with me as well? My email is [redacted]

Thank you!

1 Like

Could you please share it with [redacted] as well

1 Like

I also need the SDK. Please share via email: [redacted]

1 Like

I’m having some trouble integrating the new cordova plugin. Here’s what I did:

  • I extracted the zip file and copied the folder Libs/Zoom from the zip file to lib/cordova.plugin.zoom into the root of my ionic project.
  • In package.json I replaced "cordova.plugin.zoom": "^4.6.2166-6.603", with "cordova.plugin.zoom": "file:./lib/cordova.plugin.zoom",, so it uses the local version of the library.
  • npm install
  • ionic cap sync

Now in Android Studio I’m getting an error on gradle sync:
No variants found for ':capacitor-cordova-android-plugins'. Check build files to ensure at least one variant exists.
There have never been any build variants in capacitor-cordova-android-plugins/build.gradle defined. Even when I add the same as in the app/build.gradle, the error persists.

In XCode it gives me the error
.../ios/capacitor-cordova-ios-plugins/sources/Cordova.plugin.zoom/Zoom.h:9:9: 'MobileRTC/MobileRTC.h' file not found

I cleaned everything pretty thoroughly after updating (git clean, Clean build folder, etc…)

Any hints, suggestions?

EDIT:
In the plugin in file src/android/build-extras.gradle I had to remove the line:

apply plugin: 'com.android.application'

AFAIK, the Android plugin is applied in the App’s project and shouldn’t be applied twice.

Next issue seems to be with a setting in the AndroidManifest in the mobilertc library:

Manifest merger failed : Attribute application@allowBackup value=(true) from AndroidManifest.xml:6:9-35
	is also present at [:mobilertc:] AndroidManifest.xml:82:9-36 value=(false).
	Suggestion: add 'tools:replace="android:allowBackup"' to <application> element at AndroidManifest.xml:5:5-43:19 to override.

I had to set the allowBackup property of our application also to false to make it work. I think the mobilertc library shouldn’t set the field at all.

EDIT 2:

I finally also got iOS running. In the plugin’s plugin.xml is this line:

 <!-- <framework custom="true" embed="true" src="libs/ios/MobileRTC.xcframework" /> -->

which is not commented out in the older version of the plugin. I uncommented the line and now the project builds and I can join Zoom meetings again.

If this info helps anyone, please give a :heart:.

2 Likes

I am getting following error while building android

Could not determine java version from '11.0.16."

tried with java version 18 and getting same error.

somehow if i am able to get rid of this error then i get following error

Execution failed for task ‘:app:complieDebugJavaWithJavac’.

1 Like

Could you please share it with [redacted] as well

1 Like

Hello!

Could you please share it with me as well? My email is [redacted]

Thanks!

1 Like

Hi, i have extracted the zip file and copied the folder Libs/Zoom from the zip file to lib/cordova.plugin.zoom into the root of my ionic project.

i have built the app with android api level 29. zoom meeting can be connected from the app.
but i was unable to submit the app to play store as minimum api level required by play store is 31 now. So, i updated the android api level to 32.

Now when i click on join meeting button, app crashs.

Please help asap.
Thanks

Somehow the success building iOS was just temporary. Now it fails while linking the app with

ld: framework not found MobileRTC

I tried all the things here, but none of it worked. I’m not a Mac/iOS dev and I don’t fully understand dependencies in XCode. Could someone please help with some screenshots how it shall look like in Xcode?

EDIT:

Has anyone got it ever working on iOS?

The old plugin contained a binary, which might be the actual zoom library:

$ file libs/ios/MobileRTC.framework/MobileRTC
libs/ios/MobileRTC.framework/MobileRTC: Mach-O universal binary with 2 architectures: [arm_v7:Mach-O dynamically linked shared library arm_v7Mach-O dynamically linked shared library arm_v7] [arm64]
libs/ios/MobileRTC.framework/MobileRTC (for architecture armv7):	Mach-O dynamically linked shared library arm_v7
libs/ios/MobileRTC.framework/MobileRTC (for architecture arm64):	Mach-O 64-bit dynamically linked shared library arm64

The new plugin does not contain that file, but it contains an ominous other file with a similar size:

 file libs/ios/MobileRTC.xcframework/ios-arm64_armv7/MobileRTC.framework/GNUSparseFile.0/MobileRTC
libs/ios/MobileRTC.xcframework/ios-arm64_armv7/MobileRTC.framework/GNUSparseFile.0/MobileRTC: data

After some fiddling with a hex editor, I suspect that it might be the zoom library, but I’m not that versed in binary reverse engineering to make something out of it.

@chunsiong.tan Could you take a look if the plugin you mailed out actually works for iOS or maybe there is some wrong stuff in the ZIP file (looking at the other issues, I found and remedied … :roll_eyes: )

EDIT 2:

I don’t know what kind of scavenger hunt Zoom is playing with us here…

I finally got the sparse file back to a univeral binary with xsparse. Next I had to change the plugin-structure to be single-architecture again (.framework instead of .xcframework) using the old plugin as reference. And now it seems to work. :rocket:

Hi Martin,
Are you able to build it for android?

Hi @bhamra

Yes, there were also some things to fix. See my earlier post for details.

I’m still not there yet. Now Xcode gives the error Reached end of file while looking for: Mach-O slice..

Unfortunately it does not specify which file the error occurred on. I am pretty certain it’s a result of all the hacking required to make the new cordova-zoom-plugin work…

It would be great if they could just provide us with a working solution, where I don’t have to spend countless hours fixing random errors while our costumers can’t use our product properly.

@chunsiong.tan What’s your role within Zoom?

@martin.ley

I am also working on it for last 3 days still no success. Zoom team should provide us working library. They are also providing version 5.7.6 which will again stop working after Nov 5, 2022.

@chunsiong.tan
Please provide us updated and working solution for ionic.

Thanks

Hi,

Ionic has been official out of support for a while now. Nonetheless the version shared is provided as a break fix for the current upgrade requirement.

Moving forward, he upgrade path would be towards iOS and Android SDK.

Probably the last post of me in this thread, and going a bit off-topic:

I know it’s not officially supported. I am thankful that you got at least something for us, but on the other hand a bit surprised about the state and quality.

Using the native iOS and Android SDK wont be an option for us, because we don’t have the resources to do that (either using the existing cordova plugin as a base or developing something new). Do you think the Zoom web SDK might work as a replacement in an Ionic app?
We’re also evaluating other options, e.g. BigBlueButton. So If you want us to stick with you, your SDKs should deliver what they promise:

  • Easy to use: Our SDK is built to be easy to use. Just import the libraries, call a few functions, and we will take care of all video conferencing related stuff for you.