Unable to join meeting ionic app

Thanks @j.schoenemeyer

I have already resolved Bluetooth permission error.
New error is
java.lang.RuntimeException: Unable to create service com.zipow.videobox.share.ScreenShareServiceForSDK: java.lang.IllegalArgumentException: com.harpreet.academy: Targeting S+ (version 31 and above) requires that one of FLAG_IMMUTABLE or FLAG_MUTABLE be specified when creating a PendingIntent.

Many users has reported this error but no solution has been provided by Zoom Team yet.

If you set targetSdkVersion 31 or above you will get this error. Zoom Android SDK doesn’t fully support Android 12.

@martin.ley
Thanks for your help. I have successfully build android app which is working fine on android 12 as well.
but Zoom Team should provide solution for targetSdkVersion 31 or above.

Could you please share the sdk over email. My email Id is
[redacted]

@chunsiong.tan Thanks for all your help so far. Our current scenario is we have an Ionic app which is using the old SDK. What would be the correct path moving forward to continue using Zoom on our Ionic App without missing any of the current functionalities?

We considered moving to the Web SDK but currently it doesn’t support Gallery View and 720p video on mobile browsers (we have several customers using Android tablets and iPads).

Switching over to RN or native won’t be a viable solution as your temporary fix will be discontinued in Nov 5th, we don’t have time to write the app from scratch.

Please advice.

Hello Chung!

Could you please share it with me as well? My email is

redacted

Thank you!

Hello Chung!

Could you please share it with me as well? My email is [redacted]

Thank you!

Hello Chung!

Could you please share it with me as well? My email is [redacted]

Thank you!

Hello Chung!

Could you please share it with me as well? My email is [redacted]

Thank you!

Ionic has been official out of support for a while now. Nonetheless the version shared is provided as a break fix for the current upgrade requirement.

Moving forward, the upgrade path would be towards iOS and Android SDK.

There is a chance (unofficial) you might be able to upgrade ionic to the latest meeting SDK, but there is no official support provided for troubleshooting.

Hello Chung!

Could you please share it with me as well? My email is [redacted]

Thank you!

Hi there,

Where can I find this break fix version?

" Ionic has been official out of support for a while now. Nonetheless **the version shared is provided as a break fix for the current upgrade requirement ."

where is the break fix version?

I can’t reach the 5.4 version in the repository:

Lastest it’s 5.36.0

Hi @chunsiong.tan,

We also have an application developed in ionic that is put into production.

Could you share the solution shared that you mention in the forum to the email even if it is not the official one?

Since we are testing to update the plugin using the Native SDKs, but I have not yet succeeded.

My email is [redacted]

Thank you very much for your help

Hi @chunsiong.tan

We also have an application developed in ionic that is put into production.
Could you please share the solution over email.

my email id is [redacted]

Thank you

Hi,

Is there anyone who is able to successfully update ionic to 5.9.0 or above as minimum version requirement is 5.9.0 after 5 November.

Please help

Hey all and @chunsiong.tan,

I’ve got myself into a bit of a bind because of the Ionic plugin, and it’s affecting a major client.
I’ve started working with the break fix, but I’ve got myself into a bit of a dead end, so I was wondering if anyone has any ideas on getting around this part: Trying to build the ionic sample app, I get this issue:

Android resource linking failed
     ERROR:/home/fonemd/.gradle/caches/transforms-3/fe1bfd91c65e607c8365c56b4dc31e91/transformed/jetified-mobilertc/res/values/values.xml:2753:5-2758:10: AAPT: error: style attribute 'attr/itemRippleColor (aka us.zoom.ionicdemo:attr/itemRippleColor)' not found.

I’m using material 1.0.0.rc-1 and androidx.appcompat 1.0.0 SDK 30 and build tools 30.0.0 and Gradle 7.3.3

I’ve tried with material 1.1.0 and androidx.appcompat 1.1.0 as well, and I get the same error.

Hoping someone has seen and solved this issue… Google has failed me!!!

Hi Chung!

Could you please share it with me. My email is [redacted]
Thank you!

could you please share its version [redacted]

hey @martin.ley @bhamra can you guys help me with it or can share sdk

As it happens that the latest version of the ionic plugin will also cease to work within a few weeks and there is no update from Zoom Inc., I took a look at the plugin and adapted it to work with the latest zoom SDK for Android and iOS.

But beware: I tested only the features that our use-case requires, which is joining existing meetings without login as guest. I cannot provide any active support for this plugin, but I am happy to accept pull/merge requests.

@chunsiong.tan AFAIK the Cordova/Ionic plugin was published under the ISC license, which allows it to be modified and redistributed. If you feel I violated any copyrights, please let me know, and I will take it down. The project does not contain the binary Zoom libraries, only the JS, Java and Objective-C wrapper code of the cordova plugin.

2 Likes