Use of API to create a meeting


#1

Hello , i’ve been unsuccessfully trying to create a meeting through the use of an API provided by ZOOM. I’ve used the API’s sample code in order to test the functionality of the previously mentioned API. After multiple requests and tweaks i keep receiving a code:300 with the message: Unsupported Content Type. Could you give me a hint/example in order to get a functioning request?

This is the code for the request that i’ve been sending(obviously userId and token substituted with the corresponding values)

 

curl https://api.zoom.us/v2/users/{userID}/meetings?access_token={token}-H ‘Content-Type:aplication/json’ -d ‘{
    “topic”: “string”,
    “type”: “integer”,
    “start_time”: “string 2018-10-31 22:44:33”,
    “duration”: “integer”,
    “timezone”: “string”,
    “password”: “string”,
    “agenda”: “string”,
    “recurrence”: {
        “type”: “integer”,
        “repeat_interval”: “integer”,
        “weekly_days”: “integer”,
        “monthly_day”: “integer”,
        “monthly_week”: “integer”,
        “monthly_week_day”: “integer”,
        “end_times”: “integer”,
        “end_date_time”: “string 2018-10-31 22:44:33
    },
    “settings”: {
        “host_video”: “boolean”,
        “participant_video”: “boolean”,
        “cn_meeting”: “boolean”,
        “in_meeting”: “boolean”,
        “join_before_host”: “boolean”,
        “mute_upon_entry”: “boolean”,
        “watermark”: “boolean”,
        “use_pmi”: “boolean”,
        “approval_type”: “integer”,
        “registration_type”: “integer”,
        “audio”: “string”,
        “auto_recording”: “string”,
        “enforce_login”: “boolean”,
        “enforce_login_domains”: “string”,
        “alternative_hosts”: “string”
    }
}’


#2

HI,

My 2c:

  1. try add 

-H “accept:application/json” 

  1. try put some valid values for those “string” and “integer” fields, and most of them are optional so don’t use it unless required. For my test to create an instant meeting (type:1), I only use 2 fields as below and it worked. I used double quotes everywhere, so need to escape each of the ones inside.

-d “{ “topic”: “test”, “type”:1}”

 3. you need a space between the end of token and the beginning of “-H” to separate them.

Hope this helps.

 

Cheers