User managed app cannot GET /users/me with access token... Zoom gives "does not contain scopes" error

Every GET /users/me request (with a header having the bearer token from the oauth token exchange) returns a message: "Invalid access token, does not contain scopes:[user:read:user:admin, user:read:user]."

My app has user:read:user scopes (and I’ve tried adding every available user scope to no avail) but user:read:user:admin scopes do not exist for user-managed apps.

According to the documentation, user-managed apps can make requests to user endpoints with “me” as a user id

  • GET users/me docs state “For user-managed apps, pass the me value instead of the userId parameter”

I’ve followed all tutorials for oauth and have even cloned example repos from the Zoom’s official github, and am still getting the same error. Here are some of the samples which should work but do not for a user-managed app

How To Reproduce
Steps to reproduce the behavior:

  1. Create a user-managed app
  2. Set up oauth and add user:read scopes to your app
  3. Complete oauth token exchange to get access and refresh tokens
  4. Attempt to make a GET /users/me request with access token as bearer token in Authorization header … see that you get an error response

I would like to share links to supporting zoom docs and zoom github repos but zoom will not allow it