User's Api request not giving exact response as per the documentation (missing fields custom attributes from the response))

User API endpoint’ response not providing custom attributes in the response


  • We are trying to retrieve the data for custom attributes for the users, but the response is something weird we are unable to get the response for the field even after using the include fields in the request param, is there something which we are missing or is it the behavior of custom attributes in the specific version?

No Error messages

Can you share an example of the response that you’re seeing?

@MaxM @appflowpersistent You need to add custom attributes from -> User Management -> Users -> Advance -> Add Custom Attributes For Users and then update that custom attribute value from the user update (PATCH) request.

Then request ->

There will be custom_attributes in response e.g :point_down:

1 Like

Hi Max,

Please find the below response which we are getting, we have tried to update existing data with the custom attributes from the PATCH request but still we are not able to get the response for the custom attributes:
“id”: “aLtcWIaqRYqR75aLI-WA0w”,
“first_name”: “test”,
“last_name”: “Sandhya”,
“email”: “***************”,
“type”: 1,
“pmi”: 3615137486,
“timezone”: “Asia/Calcutta”,
“verified”: 1,
“dept”: “”,
“created_at”: “2022-02-17T08:59:21Z”,
“last_login_time”: “2022-04-14T09:24:16Z”,
“group_ids”: [
“language”: “en-US”,
“status”: “active”,
“role_id”: “1”,
“user_created_at”: “2022-02-17T08:57:51Z”

Hi @appflowpersistent, do you have added custom_attributes from account settings, as I mentioned


B/c you can only update custom_attributes value not add those using Patch request.

Then you can update the values of custom_attributes by patch request. And then request with ?include_fields=custom_attributes :point_down:

You will have custom_attributes in response e.g :point_down:

Note: When you are updating (PATCH request) custom_attributes without pre-manually added then there will be nothing happened to your account.

If still any problem please share. Thanks

1 Like

Hi Naeem,

It worked, able to get the data now.

Thanks & Regards,
Nipun Agrawal

1 Like