"Waiting for host" message after starting meeting with .startMeeting

After trying to start a meeting with .startMeeting(MobileRTCMeetingStartParam4WithoutLoginUser) as shown in the below example. The meeting window pops up, but the message “Waiting for host to start this meeting” is shown and the meeting does not begin.

Which version?

To Reproduce(If applicable)
Steps to reproduce the behavior:
I am attempting to initiate a meeting as host like this:

let params = MobileRTCMeetingStartParam4WithoutLoginUser()
params.meetingNumber = self.meeting_id
params.zak = self.zak
params.userName = currentUsername()
params.userID = currentUsername()
params.userType = MobileRTCUserType_APIUser
meetService.startMeeting(with: params)

Smartphone (please complete the following information):

  • Device: iPhone 6 Plus
  • OS: iOS 12.4.8

I am having this same issue

I am have the same issue as well.
We randomly get this message sometimes on some machines.

Please help

Hello @l.wyatt,

Thanks for using the dev forum!

Just to cover all of our bases, is the user in the above code the intended host?

If so, would you be able to recreate the bug one more time and send SDK logs to developersupport@zoom.us? Please tag this post, and I will forward this issue to the team. To obtain the SDK logs, please follow the instructions at the bottom of this page: https://marketplace.zoom.us/docs/sdk/native-sdks/iOS/mastering-zoom-sdk/sdk-initialization
The logs will be encrypted, which is intended :slight_smile:

I will work to reproduce this issue as well.


Thank you for your response Michael! I have double checked that the user in the above code is the intended host. I have also just now sent your team my SDK Logs, hopefully you find them useful :slight_smile:

1 Like

Hey @l.wyatt

Awesome! Thank you so much.

I will let you know when I have updates.


1 Like

Hi @Michael_Condon, just checking in on this issue to see if I could provide any additional info to help figure this out. Thanks!

Hey @l.wyatt

Sorry for the delay, the team is still investigating the issue.


Hey @l.wyatt,

Can you try this once more with “Join before host” enabled?