Host cannot start a scheduled meeting via macOS SDK

Description
Host cannot start a scheduled meeting via macOS SDK. Trying to start a scheduled meeting as a host via the SDK results in getting stuck the waiting room with a message saying waiting for the host even though we are the host. This is reproducible 100% of the time with the macOS ZoomSDKSample app, see repro steps below.

This should recognize that we are starting the meeting as the host and let us in as the host without seeing the waiting room or being treated as a participant.

Which version?
macOS SDK v5.0.24433.0616

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Log into zoom.us (or the actual Zoom app) and schedule a meeting. Note the Meeting ID.
  2. Update the meetingNumber param on line 46 of the file ZMSDKApiMeetingInterface.m from 0 to the Meeting ID generated from Step 1.
  3. Open the macOS ZoomSDKSample application, enter your JWT, select “RestAPI without Login” and enter your UserID and a generated ZAK. (Make sure you’re using the same user that created the meeting from Step 1) Press the “Video Meeting” button to start a meeting.
  4. Notice the popup that says “Please wait for the host to start this meeting” despite the fact that we are the host and called the function to start the meeting (startMeetingWithZAK)

Screenshots

Step 2:

Step 3:
Screen Shot 2020-07-31 at 4.53.18 PM

Step 4:

Device Info:

  • OS: macOS 10.15.5

Hi @daves,

Thanks for the post. This behavior sounds unexpected. Could you provide the SDK log for us to further investigate what is going on? You could enable the log feature by calling - (void)enableDefaultLog:(BOOL)enable fileSize:(unsigned int)size before initializing the SDK and you could find the SDK log in the following location: (~/Library/Logs/appName)

Thanks!

1 Like

Thanks for the quick response and attention, @Carson_Chen!

Let me know if this log is sufficient, I enabled logging and ran through all the steps I outlined in the previous message. Please let me know if there’s more I can do / provide to be more helpful!

Couldn’t upload it here so I threw it on my GDrive: https://drive.google.com/file/d/1UOMmKYn76sGXmy5ZoNFM_lKSNYRnvah5/view?usp=sharing

Dave

I ran into this this week. Note that the SDK gives you no indications that the ZAK is not valid. It just joins the meeting as a participant. Set params.zak = "any silly string" and you will get the same result. My guess is you are not parsing the ZAK getter response properly.

Thanks, @lucas. I appreciate your suggestion but I’m confident that I’m using a valid ZAK as I have been able to start instant meetings with the ZAKs I generate.

@Carson_Chen - looking forward to hearing your response after reviewing my logs and please let me know if I can do anything else to help.

Hi @daves,

Thanks for the log file. Based on the log, it looks like the ZAK does not belong to the host, so the user is joining a meeting that does not enable “Join before host” feature so it enters the “Waiting for the host” UI.

Could you share how you retrieve the ZAK token? Are you getting the ZAK from https://marketplace.zoom.us/docs/api-reference/zoom-api/users/usertoken?

Thanks!