Webcam initialisation fails in Google Chrome w/ client web SDK v2.1.0

Apologies if this has already been reported, I couldn’t find open discussions when searching for the error messages.


Starting with v2.1.0 of the Web SDK Client View, the webcam feed fails to initialise when clicking “Start Video” within the meeting UI. This seems to be in Google Chrome only.

I get the following error message as a toast at the top of the meeting UI:

Your camera is not launched properly, please check browser media permission settings.

This happens after I’ve granted permissions to access the webcam. Interestingly, the video feed works fine on the “Preview” screen before joining the meeting. It’s only the video inside the meeting that fails to initialise.

Browser Console Error

For every press of “Start video”, I can see the following two entries in the logs:

zoom.js:2 dpiObject {width: 0, height: 0}
1506_js_media.min.js:1 Error: media stream is ok, but start video capture fail
    at 1506_js_media.min.js:1
    at m (1506_js_media.min.js:1)
    at Generator._invoke (1506_js_media.min.js:1)
    at Generator.D.forEach.e.<computed> [as throw] (1506_js_media.min.js:1)
    at a (1506_js_media.min.js:1)
    at u (1506_js_media.min.js:1)

Which Web Meeting SDK version?

v2.1.0. I think I got a similar issue on v2.0.1 once, but on v2.1.0 it’s systematic.

Meeting SDK Code Snippets

import { ZoomMtg } from '@zoomus/websdk';

import './zoom.scss';

const DEBUG_MODE = new URLSearchParams('debug');

ZoomMtg.setZoomJSLib(`${window.STATIC_URL}zoom`, '/av');

ZoomMtg.i18n.load(window.ZOOM_LABELS_API_URL, 'en-CUSTOM');

    showMeetingHeader: false,
    disableInvite: true,
    disableCallOut: true,
    disableRecord: true,
    disableJoinAudio: false,
    audioPanelAlwaysOpen: false,
    isSupportAV: true,
    isSupportChat: true,
    isSupportQA: false,
    isSupportCC: false,
    isSupportPolling: false,
    isSupportBreakout: false,
    screenShare: true,
    videoDrag: false,
    sharingMode: 'both',
    videoHeader: true,
    isLockBottom: true,
    isSupportNonverbal: false,
    isShowJoiningErrorDialog: true,
    disablePreview: false,
    disableCORP: true,
    disableVoIP: false,
    disableReport: true,
    meetingInfo: [
    debug: DEBUG_MODE,
    leaveUrl: window.ZOOM_LEAVE_URL,
    success() {

            meetingNumber: zoomData.meeting_number,
            userName: zoomData.username,
            signature: zoomData.signature,
            apiKey: zoomData.api_key,
            passWord: zoomData.password,

To Reproduce(If applicable)

  1. Join a Zoom meeting with the web SDK client view in Chrome
  2. Attempt to “Start video”


Device (please complete the following information):

I have tested this on two different devices with 3 different Chrome versions.

  • Device: Macbook Pro
  • OS: macOS 12.0.1
  • Browser: Chrome
  • Browser Version: Version 96.0.4664.55 (Official Build) (x86_64)

And same device but with Chrome Canary:

  • Browser Version: Version 98.0.4755.0 (Official Build) canary (x86_64)

And finally a Windows 11 laptop:

  • Device: ASUS ROG
  • OS: Windows 11 Home
  • Browser: Chrome
  • Browser Version: Version 96

I could reproduce the issue in all three cases.

Additional context

  • My integration was working as expected with v1.9 releases
  • I also tried this latest version in Safari and Firefox on macOS 12, and the video feed worked fine in both browsers.

I had the same problems on 2.1.0, I needed to go back to 2.0.1 to have video working (now I’m using component but similar problem with video)

1 Like

It looks like v2.1.1 released 12 hours ago addresses this issue. I don’t have the time to try the new release at this time so would appreciate to hear confirmation from Zoom folks.

1 Like

@thibaud.colas @gabriele.guidi That’s correct, this was resolved with 2.1.1.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.